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How to Use This Course
This course introduces the functionality of the Acumatica Report Designer. The course is based on
a set of examples demonstrating data retrieval and processing to form data representations. The
course is intended for advanced Acumatica ERP users who are familiar with the user interface and main
principles of the system. Acumatica ERP application specialists and engineers might find the course
useful as well. On completing the course, you will have an understanding of how to use the Acumatica
Report Designer to create reports.

This course must be completed on Acumatica ERP 2021 R1. For this course, you will use an Acumatica
ERP tenant with the U100 dataset preloaded.

You perform the following general steps to complete the course:

1. You prepare an Acumatica ERP 2021 R1 instance, as described in How to Create a Tenant with the U100
Dataset.

2. You install the Acumatica Report Designer, as described in Report Designer: To Install the Acumatica
Report Designer.

3. In the prepared tenant with the U100 dataset preloaded, you complete all the lessons.

4. At Partner University, you take S150 Certification Test.

5. At Partner University, you complete the course survey to finish the course and get the Partner
University certificate of course completion.

What Is in This Guide

The guide includes the Company Story topic and process activities. Company Story explains the
organizational structure of the company preconfigured in the U100 dataset, as well as the company's
business processes and requirements. Each of the process activities of the course is dedicated to a
particular user scenario and consists of processing steps that you complete.

The process activities are independent and can be completed in any order.

What is in Each Lesson

Each lesson describes a concept you are learning and includes at least one activity that you have
to complete in the Acumatica Report Designer to practice the use of the functionality described in
the concept. Each activity in a lesson provides a story describing a particular user scenario, a brief
overview of the process that should be performed to complete the described scenario, and instructions
that guide you through the process in the Acumatica Report Designer.

The lessons and activities are independent and can be completed in any order.

What Are the Documentation Resources

The complete Acumatica ERP documentation is available on https://help.acumatica.com/ and is included
in the Acumatica ERP instance. While viewing any form used in the course, you can click the Open
Help button in the top pane to bring up a form-specific Help menu; you can use the links on this menu

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=cb35dc59-7955-43e6-8e90-6c626afa8f1c
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=cb35dc59-7955-43e6-8e90-6c626afa8f1c
https://help.acumatica.com/
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to quickly access form-related concepts and procedures and to open a reference topic with detailed
descriptions of the form elements.

What Files Are Provided with the Course

The S150_Files_for_Training.zip archive file is provided with this course. It includes files (copies of
predefined reports and an image) that you will use in the lessons of this course.

How to Create a Tenant with the U100 Dataset

To add to an existing Acumatica ERP instance a tenant with the U100 dataset, which is required for the
completion of this course, and prepare the tenant for completing the activities, perform the following
instructions:

1. Go to Amazon Storage.

2. Open the folder of your Acumatica ERP instance version.

3. In this folder, open the Snapshots folder, and download the u100.zip file.

4. Launch the Acumatica ERP instance, and sign in.

5. Open the Tenants (SM203520) form, and click Add New Record on the form toolbar.

6. In the Login Name box, type the name to be used for the tenant.

7. On the form toolbar, click Save.

8. On the Snapshots tab, click Import Snapshot.

9. In the Upload Snapshot Package dialog box, select the u100.zip file, which you have
downloaded, and click Upload.

The system uploads the snapshot to the Snapshots tab of the Tenants form.

10. On the form toolbar, click Restore Snapshot.

11. If the Warning dialog box appears, click Yes.

12. In the Restore Snapshot dialog box, make sure that the correct snapshot package is being
uploaded, and click OK. The system will restore the snapshot and sign you out.

You are now on the Sign-In page, and you can sign in to the tenant you have just created.

Licensing Info

For the educational purposes of this course, you will use Acumatica ERP under the trial license, which
doesn't require activation and provides all available features. For production, you have to activate the
purchased license; each particular feature may be a subject to additional licensing; please consult the
Acumatica ERP sales policy for details.

http://acumatica-builds.s3.amazonaws.com/index.html?prefix=builds/21.1/
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3f8ba9f5-9e04-4568-a93e-862ba7b92c2b
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3f8ba9f5-9e04-4568-a93e-862ba7b92c2b
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Company Story
This topic explains the organizational structure and operational activity of the company with which you
will work during this training.

Company Structure

The SweetLife Fruits & Jams company is a midsize company located in New York City. The company
consists of the following branches:

• SweetLife Head Office and Wholesale Center: This branch of the company consists of a jam factory
and a large warehouse where the company stores fruit (purchased from wholesale vendors) and
the jam it produces. Warehouse workers perform warehouse operations by using barcode scanners
or mobile devices with barcode scanning support.

• SweetLife Store: This branch has a retail shop with a small warehouse to which the goods to be
sold are distributed from the company's main warehouse. This branch is also planning on selling
goods via a website created on an e-commerce platform to accept orders online. The e-commerce
integration project is underway.

• Service and Equipment Sales Center: This branch is a service center with a small warehouse where
juicers are stored. This branch assembles juicers, sells juicers, installs juicers, trains customers'
employees to operate juicers, and provides juicer servicing.

Operational Activity

The company has been operating starting in the 01-2020 financial period. In November 2020, the
company started using Acumatica ERP as an ERP and CRM system and migrated all data of the main
office and retail store to Acumatica ERP. Because the company has grown, the equipment center has
begun its operations in 01-2021.

Company Purchases

The company purchases fruits and spices from large fruit vendors for sale and for jam production.
For producing jams and packing jams and fruits, the company purchases jars, labels, and paper bags
from various vendors. For the internal needs of the main office and store, the company purchases
stationery (printing paper, pens, and pencils), computers, and computer accessories from various
vendors. The company also purchases juicers and juicer parts for sale from a large juicer vendor and
either purchases the installation service for the juicers or provides the installation service on its own,
depending on the complexity of the installation.

Company Sales and Services

Each company's branch has its own business processes, as follows:

• SweetLife Head Office and Wholesale Center: In this branch, jams and fruit are sold to wholesale
customers, such as restaurants and cafés. The company also conducts home canning training at
the customer's location and webinars on the company's website.

• SweetLife Store: In the store, retail customers purchase fresh fruit, berries, and jams, or pick up
the goods they have ordered on the website. Some of the goods listed in the website catalog are
not stored in the retail warehouse, such as tropical fruits (which are purchased on demand) and
tea (which is drop-shipped from a third-party vendor).
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• Service and Equipment Sales Center: This branch assembles juicers, sells juicers, provides training
on equipment use, and offers equipment installation, including site review and maintenance
services. The branch performs one-time endeavors as well as complex projects with their own
budgets.
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Lesson 1: Getting Started with the Report
Designer

Report Designer: General Information

The Acumatica Report Designer is a Windows application that provides visual tools to design custom
reports. With the Report Designer, you can select data for a report, calculate required values based on
the selected data, and customize the layout of the report.

Learning Objectives

In this chapter, you will learn how to do the following:

• Install the Acumatica Report Designer

• Start the Acumatica Report Designer and explore its interface

• Open and view existing reports

• Copy existing reports

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to deliver different reports that your colleagues may need for getting their jobs done. By
using the Acumatica Report Designer, you can develop reports based on the Acumatica ERP data.

Installation of the Report Designer

You install Acumatica Report Designer by using the Acumatica ERP Installer wizard. In the wizard, the
Install Report Designer check box is selected by default, as shown in the following screenshot.
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Figure: The Acumatica ERP Installer wizard

The Report Designer receives all information required for a report from the Acumatica ERP application
server. You do not need to install Acumatica ERP locally to change or develop the report; you can just
connect to a remote server by using the appropriate URL.

The User Interface of the Report Designer

To open the Report Designer, you use the following path: Start > All Programs > Acumatica >
Report Designer. This opens the main window, shown in the following screenshot.
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Figure: The main window of the Report Designer

The main window of the Acumatica Report Designer includes the following panes:

• The Design pane on the left part of the window (Item 1 in the screenshot above), which includes
the following tabs:

• Design: Displays the report layout.

• Preview: Gives you the ability to preview the report you are designing to control the
intermediate results. If your report requires parameters, they are ignored, and the report is
displayed with random data.

• The Tools pane in the top right of the window (Item 2), which provides access to the elements and
tools that you can use to design the layout of the report and add its content.

• The Properties pane in the bottom right of the window (Item 3), which includes the following tabs:

• Properties: Displays the properties of the report element selected in the Design pane. When
you select a report element in the drop-down list, the set of properties in the properties list
corresponds to the selected element. By using the buttons above the properties list, you
can change the order of the properties according to the categories of the properties or in
alphabetical order of the names of properties.

• Fields: Lists all the fields of the data access classes selected as the source of data for the
report.

The Report Designer window toolbar, shown in the following screenshot, provides single-click access to
common actions, which are also accessible in the Report Designer menu bar.

Figure: Report Designer window toolbar
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Predefined and Custom Reports in Acumatica ERP

In Acumatica ERP, you can find a number of predefined reports for any part of the system's
functionality. These predefined reports are delivered with the system. By using the Acumatica Report
Designer, you can expand the set of reports that satisfy your company needs by creating new reports
and customizing existing ones.

We recommend that you leave predefined reports intact; if you want a report that is similar
to an existing one, make a copy of the existing report, and modify this copy.

You can view reports published in the system in the Acumatica ERP interface. In most workspaces,
predefined reports are listed in the Reports category. You can add reports that you develop with the
Report Designer to this category of any workspace.

The Location of Reports

You can store reports that you develop by using the Report Designer either locally or on the Acumatica
ERP server. (We recommend that you store reports on the server.) For more details about the location
of reports, see Report Creation: General Information.

Report Designer: To Install the Acumatica Report
Designer

In the following activity, you will learn how to install and launch the Acumatica Report Designer.

Story

Suppose that you are a technical specialist in your company who is working on customizations. An
accountant of the company has requested a number of reports that are not among the predefined
reports. You need an application to develop reports based on the data of Acumatica ERP and have
decided to use the Acumatica Report Designer, which is included in the Acumatica ERP installation
package.

Process Overview

In this activity, you will start the installation. In the Acumatica ERP Installer wizard, you will select the
option to install the Acumatica Report Designer. After the application is installed, you will start it.

System Preparation

Download AcumaticaERPInstall.msi from the following folder: http://acumatica-
builds.s3.amazonaws.com/index.html?prefix=builds/<buildNumber>, where buildNumber is the
build that corresponds to the build of Acumatica ERP that is installed in your company.

Step 1: Installing the Acumatica Report Designer

To install the Acumatica Report Designer, do the following:

1. On your computer, start AcumaticaERPInstall.msi.

The Acumatica ERP Installer wizard starts.
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2. On the Main Software Configuration step, be sure the Install Report Designer check box is
selected (the default setting), and clear the other check boxes.

3. Continue the installation process.

4. When the installation is finished, close the window of the Acumatica ERP Installer wizard.

Step 2: Starting the Acumatica Report Designer

To start the Acumatica Report Designer, do the following:

On the Windows Start menu, select All Programs > Acumatica > Report Designer.

The Acumatica Report Designer is displayed.

Report Designer: To Copy an Existing Report

In the following activity, you will learn how to copy an existing report, which can be a predefined
report or a report designed through the Acumatica Report Designer (for example, a report created by a
colleague who works on customizations).

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company, and you are working on customizations.
An accountant of the company has requested a report that displays the AR register. You have
offered the predefined AR Register (AR621500) report, which is predefined in Acumatica ERP, but the
accountant has asked for modifications to the report. You have decided to make a copy of the report
and change the copy in the Report Designer rather than directly modifying the predefined report. As a
first step, you will create and save the copy of the report.

Process Overview

In this activity, you will first open and examine the AR Register (AR621500) report in Acumatica ERP.
Then you will open the report in the Acumatica Report Designer and save a copy of it with a different
name.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=052d83b2-b676-4ebc-9ec5-6f616a98484c
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=052d83b2-b676-4ebc-9ec5-6f616a98484c
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• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Step 1: Opening and Viewing the Existing Report in Acumatica ERP

To open and view the existing AR Register (AR621500) report in Acumatica ERP, do the following:

1. On the main menu, click the Receivables menu item.

2. In the Reports category of the Receivables workspace, click the AR Register link to open the
report.

Notice that in the address bar of the browser, the ScreenId parameter is AP621500. This is the
form identifier of the report.

3. On the form toolbar, click Run Report.

The resulting report is displayed.

Step 2: Opening the Existing Report in the Acumatica Report Designer

To open the existing report in the Acumatica Report Designer, do the following:

1. On the Windows Start menu, select All Programs > Acumatica > Report Designer.

2. On the Report Designer menu bar, click File > Open From Server.

3. In the Open Report from Server dialog box, which opens, do the following:

• In the Enter Web Service URL to Load Reports List box, type the URL of your Acumatica
ERP website in the following format: http://<URL>, where <URL> is the actual URL of your
instance. The URL can be your local website or an external URL of Acumatica ERP.

• In the Login box, type your username as follows: gibbs@U100.

Make sure that your instance is named U100; otherwise, use your instance name instead of
U100 in the username.

If your instance contains one tenant in the Login box, you can specify only username.

• In the Password box, type your password as follows: 123.

• Click the Load Reports List button to load the list of reports from the website.

• In the Select Report to Load box, select AR621500.rpx, and click OK.

You can start the Report Designer and open the existing report while you are viewing this
report in Acumatica ERP. To do this, while the report form is opened in Acumatica ERP,
select the Report Versions tab and click Edit Versions. The Open Report from Server
dialog box is displayed with all the boxes filled in, except Password, Type your password
and click OK.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=052d83b2-b676-4ebc-9ec5-6f616a98484c
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The dialog box is closed, and the opened report file is displayed in the Design pane of the Report
Designer.

Step 3: Saving a Copy of the Opened Report on the Acumatica ERP Server

To save the opened report in the Acumatica Report Designer report to the Acumatica ERP server, do the
following:

1. On the Report Designer menu bar, click File > Save To Server. The Save Report on Server
dialog box opens.

2. In the Enter Report Name to Save box, type AP6215C1.rpx, and click OK.

The copy of the report is saved on the server.



| Lesson 2: Creating a Report | 15

Lesson 2: Creating a Report

Report Creation: General Information

By using the Acumatica Report Designer, you design a report to collects particular data from the
Acumatica ERP database, using any report parameters that the user has specified. The report groups,
sorts, filters, and displays results according to the settings you specify when designing the report, so
that a user running the report does not have to perform all these steps manually. Because the Report
Designer provides so much flexibility, you can gear the report design process and the resulting report
to your user-specific business needs.

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Create a report

• Publish and view a report

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to deliver different reports that your colleagues may need for getting their jobs done.

Report Development Stages

To develop a report in the Report Designer, you need to complete the following stages in the specified
order:

1. Preparation: You determine which data you need for the report and find the underlying data
access classes (DACs) and the corresponding data fields. For more information about DACs, see
Discovering DACs: General Information.

2. Data loading: You load the database schema, select the DACs that you have determined during the
previous stage, and specify relationships between DACs.

3. Layout definition: You add sections to the report layout (or delete unneeded sections from it), add
any of the visual elements available in the Tools pane of the Report Designer main window, specify
the visibility of the report sections and elements, and define the style and colors of the report. This
stage can follow the Data modification stage instead of preceding it.

For more information about adding elements on report layout, see Report Content: General
Information. For more information about report style, see Report Style: General Information.

4. Data modification (optional): You define parameters, filters, and sorting and grouping for the data
in the report. This stage can precede the Layout definition stage instead of following it.

For more information about sorting and grouping, see Data Sorting and Grouping: General Information.
For details about parameters and filters, see Parameters and Filters: General Information.

5. Saving: You save the report on the server or locally.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=51ede759-d530-4101-bb3a-274e8a922faa
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6. Publishing: You preview the report and make sure that it satisfies all the requirements. If it does
not, you modify the report. When it is ready, you publish the report: add it to the site map to make
it available in a workspace for users.

Only users with the Report Designer role are allowed to preview, save, and publish reports.

Data for a Report

You can load the database schema of all available data access classes from the application server you
use to work with Acumatica ERP. To load the database schema, you use the Schema Builder, which you
invoke by clicking File > Build Schema on the Report Designer menu bar. On the tab, you specify the
following settings:

1. The connection string (see Item 1 in the screenshot below). You use the following format: https://
<URL of your Acumatica ERP server>/<InstanceName>/, where you replace <URL of your
Acumatica ERP server> with the actual URL to your Acumatica ERP server, and <InstanceName>
with the name of your Acumatica ERP instance.

2. Your username and password in the Acumatica ERP instance (Item 2). If your application contains
more than one company, you type the appropriate company name with the username in the
following format: <username>@<company name>. The company name is the name you select when
you sign in to Acumatica ERP.

When you click the Load Schema button (Item 3), the Report Designer connects to the application
server and loads the schema. When the schema is retrieved, the list of all data access classes defined
in Acumatica ERP is displayed (Item 4).
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Figure: Loading of the schema of the data access classes

When you have loaded the database schema, you can select the data access classes you found for the
report. If your report will be based on multiple data access classes, you should specify relationships
between them. On the Relationships tab of the Schema Builder wizard, you specify the relationships
between a pair of DACs and for each pair of DACs, you specify the links between them.

Sections in a Report Layout

A layout of any newly created report consists of the following main sections:

• The page header section (see Item 2 in the screenshot below)

• The page footer section (Item 4)

• The detail section (Item 6)

Within the report, you can add group sections, which can be nested. For each group, you have the
group header (Item 3) and the group footer (Item 5) sections, and the detail section is always nested
into the innermost group. You can also add the report header (Item 1) and report footer (Item 7)
sections. All these sections are briefly described below:

• The detail section is the central part of the report, containing its main data. Unlike other sections,
it cannot be deleted. For example, if your report outlines sales orders, you would put a list of
orders in the detail section.

• The group header and group footer sections are shown at the beginning and end of, respectively,
each group of the report data. These sections are a good place for information that applies to all
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data in the detail section of the report. For example, if you group sales orders by customer, you
could place detailed information about the customer in the group header section and use the group
footer section to calculate subtotals for the customer.

• The page header and page footer sections, located at the top and bottom of every page of the
report, are the best place for information that the reader may need when reading every page. For
example, you can use the page header to display the column headers of a table that is continued
from the previous page. You can use the page footer to display the number of the current page.

• The report header and report footer sections are the only types of report sections that are printed
once per report. The report header is the second section of the report on the first page; when the
report is printed, the report header is placed right after the page header. The report header is the
best place to display the report name, the company logo, the date range of the report, and similar
information. The report footer finalizes the informative part of the report and is placed before the
page footer on the last page of the report. It is a good place for totals or conclusions.

Figure: Sections of a report layout

You can do the following with the report sections:

• Add them: You can add the report header, the report footer, the page header, and the page
footer sections to the report layout or delete them. To add these sections, you right-click any
empty space of the report layout (on the left side or on the right side), and select the appropriate
command (Item 8 in the screenshot above).

When you add a new group, its group header and group footer sections are added automatically.
To do this, you right-click any empty space in the report layout, and then select Add New Group
(Item 9 in the screenshot above). You can also add a new group in the Group Collection Editor. For
more information, see Data Sorting and Grouping: General Information.

• Delete: You may need to delete a section if it does not contain any elements, or the information in
this section is not relevant to this report. To delete any section except for the detail section, you
right-click the section header, and then select Delete, as shown in the screenshot below.
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• Duplicate: You may need to duplicate a section if, for example, you want to display content in the
section depending on some condition. To duplicate any section, you right-click the section header
and then select Duplicate.

• Hide: You may need to hide a section if data from the section is used in calculations but you don't
need to display the content of the section. To hide any section, you set the Visible property of the
section to False. You also can define a condition that allows the section to be hidden; in this case,
you specify an expression for the VisibleExpr property.

Figure: Deletion of a section

Saving of a Report

Once you create or modify a report by using the Acumatica Report Designer, you can save it locally
or on an Acumatica ERP server. You can also save your report to an Acumatica ERP website as a new
version of the report.

When you design a report, we recommend that you save the report from time to time so
that you don't lose your changes.

Reports in the Acumatica Report Designer are files with the RPX extension.

To save a new report, you can use the following commands on the Report Designer menu bar:

• File > Save to Server: You use this command if you want to save your report to the Acumatica
ERP server.

In the Save Report on Server dialog box, which opens, you specify the connection settings to the
server—that is, the connection string and sign-in credentials. You specify connection string (Item
1 in the following screenshot) in the following format: http://<URL>, where <URL> is URL of your
Acumatica ERP server. You can use http or https protocol, depending the settings of your website.
If your application contains more than one company, you type the company name with the
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username (Item 2 in the following screenshot) in the following format: <username>@<company
name>. The company name matches the name you use when you sign in to Acumatica ERP. If
your application contains only one company, you specify only the username.

You specify the name of the report (Item 3 in the following screenshot)—or, more accurately, an
identifier—in the <AA.NN.NN.NN> format, where A is a letter, and N is a digit. For information on
the identifier conventions of Acumatica ERP reports, see Form and Report Numbering.

To avoid conflicts with new reports that the Acumatica ERP engineering team could
produce in the future, we recommend that you use different report identifiers than those
described in Form and Report Numbering.

Figure: Saving of a report to the server

• File > Save or File > Save as: You use these commands if you want to save your report locally.

You can also save the report locally by clicking the  button on the Report Designer
window toolbar.

To save an existing report you can use the following commands on the Report Designer menu bar:

• File > Save. By default, the opened report file is saved to the place from which it was opened.

You can also save the opened report by clicking the  button on the Report Designer
window toolbar.

• File > Save to Server. In the Save report on server dialog box, which opens, you use the
settings that are described above for saving a new file on the server.

You can save your report to an Acumatica ERP server as a new version by selecting the Save as New
Version check box in the Save Report on Server dialog box. You can manage the active number of
a report version only in Acumatica ERP interface. If you want to use a specific report version, you need
to open the report form in Acumatica ERP, and on the Report Versions tab, select the Active check
box in the row with necessary version. After that, you can modify this version by starting the Report
Designer by clicking the Edit Report button on the report form toolbar.

After you have saved your report locally or to the server of an instance, you can use this report for any
company of this instance.

We recommend that you save your reports in the following locations:

1. The server

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4a5e6db8-cbba-4cbe-b0f1-1d774381c1b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4a5e6db8-cbba-4cbe-b0f1-1d774381c1b4
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2. The /Site/ReportsCustomized/ folder

3. The /Site/ReportsDefault/ folder

When you open a report in the Report Designer, the application searches for the report in the listed
locations in the listed order.

Report Publication

When a report is ready, you can publish it, so that users of the system can run the report. Publishing
a report entails adding the URL of the report to the site map in Acumatica ERP—that is, adding
information about the report to the Site Map (SM200520) form and saving your the changes.

On the Site Map form, you add a new row with the following settings:

• Screen ID: The identifier of the form that is used to access the report in Acumatica ERP. You
assigned this identifier when you saved your report in the Report Designer.

• Title: The name of the report. This name is displayed in the Reports category of a workspace that
you specify for the report.

• URL: ~/Frames/ReportLauncher.aspx?ID=<ScreenID>.rpx.

• Workspaces: The name of the workspace where you want to place the report; you can add the
report to multiple workspaces.

• Category: Reports.

Report Viewing and Execution in Acumatica ERP

To view a report in Acumatica ERP, you open the workspace where the report is placed, and under the
Reports category, you click the link with the report name. If needed, on the Report Parameters tab,
you specify the report parameters, and click Run Report.

To return to the report form—for example, to change report parameters—you can click the

 button on the report toolbar.

To preview the report that have not been published yet, you use the Preview tab in the Report
Designer. If your report requires parameters, they are ignored, and the report is displayed with
random data.

Report Creation: To Create a Report Based on One DAC

In the following activity, you will create a report based on one DAC.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
An accountant of your company has requested a report that collects data about invoices and memos.
The accountant wants a simple report that displays columns with the document type, invoice reference
number, and the balance of the invoice with that number.

Process Overview

You will first inspect the Invoices and Memos (AR301000) form to explore which data access classes you
can use to access the needed data: the document type, reference number, and balance.

With the knowledge you have obtained, you will create the report and add the columns to be displayed.

When the report is created and all the necessary settings are specified, you will preview and then
publish the report.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Step 1: Discovering DACs and Data Fields

To inspect the user interface elements whose data you will use for your report, do the following:

1. In Acumatica ERP, open the Invoices and Memos (AR301000) form.

2. Point to the Reference Nbr. element, press Ctrl+Alt, and then click. The Element Properties
dialog box opens. You are interested in the Data Class and Data Field values, which correspond
to the class and field you need. Notice that these values are, respectively, ARInvoice and RefNbr.
Close the dialog box.

To open this dialog box, you could instead click Customization > Inspect Element on
the form title bar and then click the Reference Nbr. element.

3. On the form, point at the Balance element, press Ctrl+Alt, and click to again open the Element
Properties dialog box. Notice that the Data Class value is again ARInvoice, while the Data Field
value is CuryDocBal. Close the dialog box.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=5e6f3b27-b7af-412f-a40a-1d4f4be70cba
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=5e6f3b27-b7af-412f-a40a-1d4f4be70cba
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4. On the form, inspect the Type element as you did in the previous instructions to find its data class
and data field. Notice that its Data Class value is again ARInvoice and its Data Field value is
DocType.

You have discovered that the data access class you need is ARInvoice and the data fields are: DocType,
RefNbr, and CuryDocBal.

Step 2: Loading the Database Schema

To load the database schema, do the following:

1. On the Report Designer menu bar, click File > New to create a new report.

An empty report with the default sections opens.

2. On the Report Designer menu bar, click File > Build Schema.

The Schema Builder opens with the Tables tab selected.

3. In the Enter Web Service URL to Load WSDL Document box, enter the URL of your Acumatica
ERP website, which can be your local website or an external URL of Acumatica ERP.

The history of successful connections is automatically saved in the drop-down list of the
URL box. For example, if you have already opened a report from the server, you can
select the URL from the drop-down list.

4. Type gibbs as the username and 123 as the password in the Login and Password boxes,
respectively.

5. Click Load Schema.

6. In the Search box, type ARInvoice.

7. In the Select Report Tables list, click ARInvoice (PX.Objects.AR.ARInvoice), and click >.

The ARInvoice data access class is placed in the right pane of the Schema Builder.

8. In the Schema Builder, click OK.

The system closes the Schema Builder.

Step 3: Adding Data to the Report

To add data to the report, while you are still working with it in the Report Designer, do the following:

1. In the Properties pane, select the Fields tab.

2. In the list of the fields of the ARInvoice data access class, drag the DocType field to the
detailSection1 section.

Notice that in detailSection1, you have a box with the following content:
[=[ARInvoice.DocType]].

3. Repeat the actions of the previous instruction with the RefNbr and CuryDocBal fields. Place RefNbr
next to DocType, and CuryDocBal next to RefNbr.
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4. In the Tools pane, drag the TextBox element to the pageHeaderSection1 section. This
element will be a heading of the column. Place the element above the element with the
[=[ARInvoice.DocType]] content.

5. While the text box is selected, in the Properties pane, on the Properties tab, for the Appearance
> Value property, enter Document Type.

6. Add two more TextBox elements to the pageHeaderSection1 section with the following
values: Reference Number and Balance. These elements will be the headers of two other
columns. Place these elements above the element with the [=[ARInvoice.RefNbr]] and
[=[ARInvoice.CuryDocBal]] content.

7. In the Tools pane, drag the Line element to pageHeaderSection1. Extend the line. This line will
divide the heading of the table in the report.

8. Add two more TextBox elements to the pageHeaderSection1 section with the following values:
Page and =[PageOf]. These elements will display the current page number and the total number of
pages in the report.

Before saving the report, preview it. In the Design pane of the Report Designer, select the Preview
tab. If you are not satisfied by the design of the report, move the text boxes to align them.

The following screenshot shows the report you have designed.

Figure: The report designed to display data about invoices and memos

Step 4: Saving the Report

To save the report on an Acumatica ERP website, do the following:

1. On the Report Designer menu bar, click File > Save to Server.

The Save Report on Server dialog box opens.

2. In the dialog box, in the Enter Web Service URL to Load Reports List box, type the URL of
your Acumatica ERP website (Item 1 in the screenshot below).

3. In the Login box, type your username, and in the Password box, type your password (Item 2).
Use the same settings that you have used in Step 2.

4. In the Enter Report Name to Save box, enter the report name: AR308000.

5. Click OK.
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Step 5: Publishing the Report

To publish the report, do the following:

1. In Acumatica ERP, open the Site Map (SM200520) form.

2. Add a new row with the following settings:

• Screen ID: AR.30.80.00

• Title: All Invoices and Memos

• URL: ~/Frames/ReportLauncher.aspx?ID=AR308000.rpx

• Workspaces: Receivables

• Category: Reports

3. Save your changes.

Step 6: Viewing the Report

To view and run the report you have created, do the following:

1. In the main menu of Acumatica ERP, click the Receivables menu item.

2. In the Reports category of the Receivables workspace, select All Invoices and Memos.

3. On the report form toolbar, click Run Report.

The created report with the information about invoices and memos is displayed. The following
screenshot shows the resulting report.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Figure: The resulting report displaying information about invoices and memos
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Lesson 3: Filling a Report with Content

Report Content: General Information

The content of a report designed in the Acumatica Report Designer includes visual elements, which
can contain text, data, and images. The visual elements are placed within the report sections, and
their appearance and behavior properties are determined by both the properties of the visual elements
themselves and the properties of the report section where they are placed.

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Add, delete, and move elements in the report layout

• Configure properties of the elements added to the report layout

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to add content—that is, data, images, charts, and subreports—to predefined reports or to
reports you create from scratch.

Types of Visual Elements in a Report Layout

You can add to the report layout any of the visual elements located in the Tools pane of the Report
Designer main window. You can add the following elements:

• TextBox: A text box is used to display text or data from the database in the report.

• PictureBox: A picture box is used to display an image in the report. For example, you can place
your company logo on the report, as you do on other company materials. You can also use the
PictureBox element to add a QR code or barcode to your report.

• Panel: A panel is a container of elements that are processed together.

• Line: A line can be used to divide the report space, direct the eye, or visually separate elements in
the report. You can add lines to improve the look and readability of the report.

• Chart: A chart is a graphical representation of data in the report. You can use different types of
charts—for example, line, bar, or pie—to present information, such as sales by month and by sales
manager.

• SubReport: You can use a subreport to include data from other reports in the current report. For
example, you can define as a subreport the list of change orders in a project or the last sheet,
which is always the same in a register. The use of subreports makes it possible to reduce the time
it takes to form a complex report that is designed to extract data from multiple related tables and
use a subselect SQL expression.
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Operations with Visual Elements in a Report

Adding content to the report generally involves three steps:

1. Adding visual elements to the report.

2. Optional: Linking the elements with the data to be displayed in the report.

3. Setting the visual elements' properties.

To add a visual element to a report section, you select the element in the Tools pane, and place it
in the desired position within the report by dragging it. You can resize the element by dragging its
borders. You can also move the element within the section or to another section.

After a visual element is added to the report, you can do the following:

• Define the style of the element

• Copy and paste the style between visual elements

• Define the order of visual elements on the screen by bringing them to the front or sending them to
the back

• Cut, copy, and paste visual elements and their content to other areas within the report

To perform these actions with a visual element, you can do the following:

• Use the actions available on the Report Designer window toolbar or menu bar

• Right-click the visual element and then select the relevant command from the shortcut menu

• Use Windows-standard combinations of keys

You can delete the selected visual element by pressing the Delete key.

For more information about the style of elements, see Report Style: General Information.

Text and Data in a Report

You use the Appearance > Value property of the TextBox visual element to specify the contents of
the text box—that is, text, a data field of the database table, or an expression. For more details about
expressions, see Variables and Expressions: General Information.

You can add the TextBox element with a field name as its content in one action by dragging the field
from the list that is located on the Fields tab of the Properties pane.

All parts of the text in a text box have the same formatting. If you need to have different formatting
for different parts of the text, you should divide the text and place it into multiple text box elements,
each of which has its own formatting.

Images in a Report

To add an image to an Acumatica ERP report, you can use the following methods:
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• Embed an image file in the report. Embedded images are stored along with the report file, and
are included in the report as its inner elements. You can add images of the following types to the
collection of embedded images: bmp, gif, jpg, and png. For embedded images, you first specify
the image that you embed as the Data > EmbeddedImages property for report1 Report. Then
you specify the following properties for the PictureBox element:

• Data > Source: Embedded

• Data > Value: the file name of the image

• Select the image from an external file. External files are stored on external resources, such as
websites or local hosts, that are accessible from the Acumatica ERP application site where the
reports are published. The report stores only the link to the external file where the image file is
located. For external images, you specify the following properties for the PictureBox element:

• Data > Source: External.

• Data > Value: The URL of the image. For example, suppose that you have uploaded the
MyImage.png file to the /Site/Images/ folder. In the Data > Value property, you should enter
the following URL: Images/MyImage.png.

• Select a data field and load an image from it. In Acumatica ERP, all images are stored in the
UploadFile table. For images inserted in a report from the database, you specify the following
specific properties of the PictureBox element:

• Data > Source: Database

• Data > Value: =[UploadFile.Name]

Report Designer considers QR codes and barcodes to be pictures. To add a QR or barcode to an
Acumatica ERP report, you add a PictureBox element and specify the following properties for it:

• Behavior > QRCodeSettings

• Behavior > BarcodeSettings

• Data > Source

• Data > BarcodeType

• Data > Value

With the Layout > Sizing property you can adjust sizing of an image so that the image can keep its
proportions, fill the whole space of the picture box, or be placed in the center of the picture box.

Charts in a Report

To define a chart in your report, you specify properties in the Chart and ChartData groups of
properties.

Subreports

You can add one subreport or multiple subreports to a single main report. If it is placed in any report
section, the entire subreport will be printed in that section, except for the page header and page footer
sections.
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Although you can insert a subreport into any report, we do not recommend that you insert a
subreport into another subreport because it can cause the server performance degradation.

Unlinked subreports are standalone reports, and their data is not linked to the data in the main report.
An unlinked subreport does not have to use the same data as the main report; it can use the same
data source or a different data source entirely. Linked subreports use data that is coordinated with
data in the main report. The Report Designer matches up the data in the subreport with the data in
the main report. If you create a main report with customer information and a subreport with order
information and then link them, the Report Designer creates a subreport for each customer that
includes all of this customer’s orders.

Before you insert a subreport into the main report, you must be sure that the subreport can be run
as an independent report. You don't need to publish a subreport—that is, to add it to the Site Map
(SM200520) form—to make sure it can be run. You can preview a subreport on the Preview tab of the
Report Designer.

The main report and subreport must be saved on the same server.

You specify the following properties for the SubReport visual element:

• Behavior > ReportName: The file name of the subreport

• Behavior > Parameters: The parameters that are passed from the main report to the subreport

Report Content: To Add an Image to a Report

In the following activity, you will learn how to add images (stored in the database) of items to a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager has requested a report that displays the details of an invoice or memo. You have
offered the predefined Invoice/Memo (AR641000) report, but the sales manager has asked you to
display images of the items in the report.

Process Overview

In the Report Designer, you will open the AR6410C1 report, which is a copy of the Invoice/Memo 
(AR641000) report, and add the PictureBox element to the report layout. You will configure the 
properties of the element.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
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1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AR6410C1.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AR6410C1 as the report name, and click OK.

The report is saved on the server.

Step 1: Adding Tables to the Report

Because the images of inventory items are stored in the UploadFile table, you need to add this table
to the report. You also need to add the InventoryItem, ARTran, and NoteDoc tables. After you add the
tables, you need to specify relations between them.

To add tables to the AR6410C1 report and build relations between the tables in the report, do the
following:

1. In the Report Designer, be sure the AR6410C1 report (which you have saved to the server) is
open.

2. On the Report Designer menu bar, click File > Schema Builder.

3. In the Schema Builder, which opens, on the Tables tab, specify the connection string and sign-in
credentials of your Acumatica ERP instance, and click Load Schema.

4. While you are still viewing the Tables tab, in the left pane, select the InventoryItem, NoteDoc, and
UploadFile tables, and add them to the right pane by using the > button.

You can search for the names of the tables by using the Search box above the left pane.

5. On the Relationships tab, do the following:

a. To link the ARTran and InventoryItem classes, add rows with the following settings to the listed
tables:
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• Enter the report table relations here table:

Parent Table Join Type Child Table

ARTran Inner InventoryItem

• Enter the data field links for the active relation table:

Parent Field Link Condition Child Field

InventoryID Equal InventoryID

b. To link the InventoryItem and NoteDoc classes, add rows with the following settings to the
listed tables:

• Enter the report table relations here table:

Parent Table Join Type Child Table

InventoryItem Inner NoteDoc

• Enter the data field links for the active relation area:

Parent Field Link Condition Child Field

NoteID Equal NoteID

c. Add the rows with the following settings to link the NoteDoc and UploadFile classes:

• Enter the report table relations here area:

Parent Table Join Type Child Table

NoteDoc Inner UploadFile

• Enter the data field links for the active relation table:

Parent Field Link Condition Child Field

FileID Equal FileID

6. In the lower right corner, click Apply and then OK to apply the changes and close the Schema
Builder, respectively.

7. On the Report Designer window toolbar, click Save.

The following screenshot shows the Relationships tab of the Schema Builder for the AR6410C1
report.
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Figure: Relations for added tables for the AR6410C1 report

Step 2: Adding the PictureBox Element to Display the Image of the Item

To add the PictureBox element to the report layout, while you are still working with the AR6410C1
report in the Report Designer, do the following:

1. Select detailSection1 and enlarge the height of the section.

For the detailSection1, you can specify the 3.5cm value for the Appearance > Height property.

2. In the Tools pane, drag the PictureBox element to detailSection1 at the left, below the text
boxes.

3. While the PictureBox element is selected, in the Properties pane, specify the following properties
for it:

• Data > Source: Database

• Data > MimeType: image/jpeg

• Data > Value: =[UploadFile.Name]

• Layout > Size > Width: 152px

• Layout > Size > Height: 96px
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4. On the Report Designer window toolbar, click Save to save the report.

Step 3: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Invoice/Memo (AR6410C1) report form by searching for its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the Report Parameters tab, in the Document Type box, make sure Invoice (the default
value) is selected.

3. In the Reference Number box, select 000058.

4. On the report form toolbar, click Run Report.

Make sure that the image corresponding to the item in the invoice is displayed, as shown in the
following screenshot.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Figure: The Invoice/Memo (AR6410C1) report with the image from the database
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Report Content: To Add QR Codes to a Report

In the following activity, you will learn how to add QR codes to reports.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager has requested a report that displays the details of an invoice or memo, including the
QR codes of items. You have decided to use the predefined Invoice/Memo (AR641000) report as a base
and modify it by adding the QR code of each item.

Process Overview

In the Report Designer, you will open the AR6410C2 report, which is a copy of the Invoice/Memo 
(AR641000) report, and add the PictureBox elements to the report layout. You will configure the 
properties of this element to display a QR code for each item in the report.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AR6410C2.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AR6410C2 as the report name, and click OK.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
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The report is saved on the server.

Step 1: Adding a QR Code of Each Item

To add a QR code of each item in the AR6410C2 report, do the following:

1. In the Report Designer, be sure the AR6410C2 report (which you have saved to the server) is
open.

2. Select detailSection1 and enlarge the height of the section.

For the detailSection1, you can specify the 3.5cm value for the Appearance > Height property.

3. In the Tools pane, drag the PictureBox element to the detailSection1 section, on the left side of
the detailSection1 section, below the text boxes.

4. To show the QR code of the item, while the PictureBox element is selected, in the Properties
pane, specify the following settings:

• Data > Source: Barcode

• Data > BarcodeType: QRCode

Based on these settings, the image will be a QR code.

• Data > Value: ='http://<URL of Your Instance>/Main?
ScreenId=AR301000&InventoryCD='+[ARTran.InventoryID]

For example, Data > Value can be the following: ='http://my-server.acumatica.com/
InstanceName/Main?ScreenId=AR301000&InventoryCD='+[ARTran.InventoryID]

Based on this value, each item will contain the QR code that is linked to the appropriate item.
Notice that the link contains the application URL explicitly.

• Behavior > QRCodeSettings > CodeSize: 64

The default CodeSize of any QR code image is 50. If the length of the string you have
specified as the Value is too long, the QR code will disappear from the image preview on the
report layout. If the user runs this report, the QR code will be invisible too. The larger the
string whose value you have specified for the barcode, the larger the CodeSize you should
specify to make the image visible.

• Layout > Size: 64px; 64px

5. On the Report Designer window toolbar, click Save.

Step 2: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Invoice/Memo (AR6410C2) report form by searching for its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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2. On the Report Parameters tab, in the Document Type box, make sure Invoice (the default
value) is selected.

3. In the Reference Number box, select 000058.

4. On the report form toolbar, click Run Report.

Make sure that QR code is displayed for each item in the invoice, as shown in the following screenshot.
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Figure: The Invoice/Memo (AR6410C2) report with the QR codes of items



| Lesson 3: Filling a Report with Content | 40

Report Content: To Embed an Image in a Report

In the following activity, you will learn how to embed an image in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager has requested that you add an image of his signature to a report that displays the
details of an invoice or memo. You have decided to use the predefined Invoice/Memo (AR641000) report
as a base and modify it by adding the image of the signature that the sales manager has sent to you
as a PNG file.

Process Overview

In the Report Designer, you will open the AR6410C3 report, which is a copy of the Invoice/Memo 
(AR641000) report, and add the PictureBox element to the report layout. You will configure the 
properties of this element to display the facsimile image.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AR6410C3.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AR6410C3 as the report name, and click OK.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=3e62d073-5d55-4ddc-8267-498ff184a5ba
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The report is saved on the server.

Upload the facsimile.png file and save it to any folder on your computer.

Step 1: Embedding the Image in the Report

To embed the image in the AR6410C3 report, do the following:

1. In the Report Designer, be sure the AR6410C3 report (which you have saved to the server) is
open.

2. On the Properties tab of the Properties pane, select the report1 Report object from the drop-
down list to select the report form, and do the following:

• In the Data > EmbeddedImages property, click the button to open the Embedded Images
dialog box.

• In the dialog box, click the New image ... button, as shown in the screenshot below, and 
select the facsimile.png file, which contains the needed image. (The Name and Mime Type of 
the selected file are defined automatically.)

Figure: The embedded image in the Embedded Images dialog box

3. Click OK to add the image you have selected to the embedded images collection of the report and
to close the Embedded Images dialog box. Now you can use this image in the report.

4. Select groupFooterSection2 (Footer of groupInvoice) and enlarge the height of the section.

For the groupFooterSection2 (Footer of groupInvoice), you can specify the 1.0cm value for
the Appearance > Height property.

5. In the Tools pane, drag the PictureBox element to the groupFooterSection2 (Footer of
groupInvoice) section, on the left.

6. Specify the following settings for the embedded image:

• Data > Source: Embedded

• Data > Value: facsimile
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• Layout > Sizing: Scale

With the Scale value of the Layout > Sizing property you adjust sizing of an image so that the
image keeps its proportions.

7. On the Report Designer window toolbar, click Save.

Step 2: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Invoice/Memo (AR6410C2) report form by searching for its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the Report Parameters tab, in the Document Type box, make sure Invoice the default
value) is selected.

3. In the Reference Number box, select any number, for example, 000058.

4. On the report form toolbar, click Run Report.

Make sure that the image you have added is displayed below the list of items in the invoice. The
following screenshot displays the report.

Figure: The Invoice/Memo (IN6410C2) report with the image added

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Report Content: To Add a Subreport

In the following activity, you will learn how to create a related subreport in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A project manager has requested a report that displays project profitability by project manager.
The project manager has also asked you to display the list of change orders for each project. You
have looked through the reports in Acumatica ERP and decided to use a copy of the Project Profitability
(PM624000) report and make modifications to it.

Process Overview

In the Report Designer, you will create the COProfit report, which will display a list of change orders 
related to projects in the primary report. As the primary report, you will use the PM6240C1 report, 
which is a copy of the Project Profitability (PM624000) report. You will insert into it the COProfit report 
as a subreport.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the PM6240C1.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b7e2b059-0a14-41da-b0dc-3ca37120d904
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b7e2b059-0a14-41da-b0dc-3ca37120d904
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4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type PM6240C1 as the report name, and click OK.

The report is saved on the server.

Step 1: Creating a Subreport

To create a subreport that lists change orders, do the following:

1. On the Report Designer menu bar, click File > New.

An empty report with the default sections opens.

2. On the Report Designer menu bar, click File > Build Schema.

The Schema Builder opens with the Tables tab selected.

3. In the Enter Web Service URL to Load WSDL Document box, enter the URL of your Acumatica
ERP website, which can be your local website or an external URL of Acumatica ERP, such as
https://mysite.com/MyAcumatica.

The history of successful connections is automatically saved in the drop-down list of the
URL box. For example, if you have already opened a report from the server, you can
select the URL from the drop-down list.

4. Type your username and password. If your application contains more than one company, type the
appropriate company name with the username in the following format: gibbs@U100.

5. Click the Load Schema button.

6. In the Search box, type ChangeOrder, and, in the Select Report Tables list, select
PMChangeOrder and click >.

The PMChangeOrder data access class is placed in the right pane of the Schema Builder.

7. On the Parameters tab, click Add to add a parameter.

8. In the Name box, type Project.

9. On the Filters tab, add a row with the following settings:

• Data Field: PMChangeOrder.ProjectID

• Condition: Equal

• Value1: @Project

10. In the Schema Builder, click Apply to apply the changes and OK to close the window.

11. In the Tools pane, drag the TextBox element to the detailSection1 section, on the left.

12. For the Appearance > Value property of the added text box, specify =[PMChangeOrder.RefNbr].

13. Right-click any empty space of the report layout and click the Add New Group command to add a
new group, groupHeaderSection1, to the report layout.
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14. In groupHeaderSection1, add a text box, and for its Appearance > Value property, specify
Change Order Reference Number. This text box will display the header of the list of change orders
for a project.

15. Optional: To highlight the header of the list of change orders for a project, do the following:

a. Select the report by clicking the  icon at the top left corner of the Design pane of the Report
Designer and for the Appearance > StylesTemplate property, select TemplateReport.rpx in
the Select Report Scheme window, in the /Site/ReportsDefault/ folder.

b. Select the text box with Change Order Reference Number and for the Appearance >
StyleName property, select GroupHighlight.

16. Optional: Right-click the header of the pageHeaderSection1 and click Delete to delete the section.
Delete the pageFooterSection1 section the same way.

17. Select groupFooterSection1, and for its Behavior > Visible property, select False to make the
section invisible.

18. On the Report Designer menu bar, click File > Save To Server to save the report.

19. In the Save Report on Server dialog box, fill in the following boxes:

• Enter Web Service URL to Load WSDL Document: The URL of your Acumatica ERP website

• Login: Your username

• Password: Your password

• Enter Report Name to Save: COProfit

20. Click OK to save the report and close the window.

COProfit.rpx is saved on the server.

The subreport that you have created is shown in the following screenshot.

Figure: The subreport that lists the change orders of the specified project

Step 2: Adding the Subreport to the Report

To insert the subreport in the PM6240C1 report, do the following:

1. In the Report Designer, open the PM6240C1 report (which you have saved to the server).

2. In the Tools pane, drag the SubReport element to the groupHeaderSection1 section, below the
text boxes.

3. In the Behavior > ReportName property of the Properties tab, type the name of the subreport
—that is, COProfit.rpx.
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4. Right of the Behavior > Parameters property, click the  button.

5. In the ExternalParameter Collection Editor, which opens, in the Members pane, click Add.

6. In the right pane of ExternalParameter Collection Editor, for the Name parameter, specify Project,
and for the ValueExpr parameter, specify =[PMProject.ContractCD].

7. Click OK to close the ExternalParameter Collection Editor.

8. On the Report Designer window toolbar, click Save.

The PM6240C1 report with the COProfit subreport is shown in the following screenshot.

Figure: Report with subreport

Step 3: Viewing the Report with the Subreport

To view the report, do the following:

1. In Acumatica ERP, open the Project Profitability (PM6240C1) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the report form toolbar, click Run Report.

The report is shown in the following screenshot. Make sure that the change orders displayed for the
project are related to the correct project. To do this, you can open Projects (PM301000) form and select
the project identifier that is displayed in the report. On the Change Orders tab, the list of change
orders should match the list of change orders in the report.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=81c86417-3bde-444b-8f1c-682928d31a0c
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Figure: The Project Profitability (PM6240C1) report with change orders
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Lesson 4: Using Variables and Expressions

Variables and Expressions: General Information

In the Acumatica Report Designer, you can use expressions to define values to be displayed in a
report, or to specify report properties, such as group conditions and the visibility of sections or
elements of the report. In expressions, you can use variables and parameters. (For more information
about parameters, see Parameters and Filters: General Information.) In the Report Designer, you can type
an expression or you can compose an expression in the Expression Editor.

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Create a variable

• Specify an expression

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You may want to perform calculations on values before presenting them or transform the data in
some way.

Variables

You can use variables to store values, make them available in all sections of the report, and substitute
values in expressions.

Global variables are available in all reports. Global variables can be inserted into a report as values or
included in expressions. The following table shows the global variables defined in the Report Designer.

Table: Global Variables

Global Vari-
able

Description

PageIndex Substitutes into the expression the page index value selected in the data source defi-
nition of the current report.

PageCount Substitutes into the expression the page count value for the current report.

PageOf Substitutes into the expression the page number and total page count values for the
current report.

You specify a local variable for the report section. This variable is visible in all other sections of the
report. If you declare the same variable in multiple sections, the variable is shared between them.
If the variable is modified in one section, the new value of the variable is passed to the next section
where the variable is used. The variable is initiated in the topmost section where it is used. Then the
variable is sequentially modified in the following sections in the order in which these sections are
printed in the report.
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To define a variable, you use the Behavior > Variables property of the report section.

The variables have the $VariableName format, where VariableName is the name of the variable
defined in the report.

The following example illustrates the use of the $RowNumber local variable in the expression.

=Assign( '$RowNumber', $RowNumber + 1 )

In a report, you can use a variable defined in a subreport. In this case, the variable has the
$ReportName_VariableName format, where ReportName is the name of the report in which the variable
is defined. For example, suppose that you have defined the $pmt variable in the payment report. If you
need to use this variable in another report in your Acumatica ERP instance, you refer to this variable as
$payment_pmt.

Addition and Deletion of a Variable in a Report Section

To define a variable, you use the ReportVariable Collection Editor (that is, the ReportVariable
Collection Editor dialog box). To open the ReportVariable Collection Editor, you select the report
section where you want to add the variable; then in the Properties pane, on the Properties tab, click
the  button next to the Behavior > Variables property.

If you add more than one variable in a section, in the ReportVariable Collection Editor, variables should
be listed in the Members list in the order they are calculated. For example, suppose that you have
specified two variables—A and B. Also suppose that $B=F($A). In this case, A should be listed first and
B should be listed second. To change the order of variables in the ReportVariable Collection Editor, you
use buttons with arrows on the left of the Members list.

To delete a variable from the list of existing variables, you open the ReportVariable Collection Editor,
select this variable in the Members list, and click Remove.

Expression Editor

You define expressions in the Expression Editor—that is, the Expression Editor dialog box of the
Report Designer. You can open the Expression Editor in the following places:

• In the Schema Builder, on the Relationships tab, by clicking the Parent Formula or Child
Formula button

• In the Schema Builder, on the Parameters tab, by clicking the  button next to the Input mask,
View name, and Default value boxes.

• In the Schema Builder, on the Filters tab, by clicking the Data Field Formula button

• In the Schema Builder, on the Sorting and Grouping tab, by clicking the Grouping Field
Formula button

• In the Appearance > Value property of the TextBox element

The Expression Editor consists of four panes, as shown in the screenshot below:

• The left pane of the dialog box (Item 1) displays a list of data access classes and their fields
defined for the report.
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• The middle pane of the dialog box (Item 2) lists groups of parameters, operators, functions, and
variables.

• The right pane of the dialog box (Item 3) contains the parameters, operators, functions, or
variables in the group you select in the middle pane.

• You use the bottom pane of the dialog box (Item 4) to compose and edit the expression. You can
double-click data fields listed in the left pane and items listed in the right pane to add them to the
bottom pane.

Figure: Expression Editor

You perform the following steps to enter an expression in the Expression Editor:

1. In the middle pane, you expand the hierarchical structure of existing entities, and select a group
of parameters, variables, operators, or functions to display the list of available items in the right
pane.

2. In the right pane, you select the item you want to insert in the bottom pane.

3. In the expression, point where you want to insert the selected item and double-click the item.

4. In the left pane, you expand the hierarchical structure of classes defined for the report, and select
a data field to insert it in the bottom pane.

5. In the expression, point where you want to insert the selected data field and double-click the field.

You can add as many items and fields in the bottom pane as you need. You can use the added
items and fields to edit the expression.

6. You validate the expression.

7. You save the expression.
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Variables and Expressions: Functions in Expressions

You can use functions to perform specific tasks that facilitate the processing of data for reports. Many
functions available in the Expression Editor process data and return values, which you can use in
reports.

To use functions in expressions, you can enter them manually in the expression editing area or select
them from the list of functions provided by the Expression Editor. You can use the following groups of
functions in expressions.

Type Conversion Functions

You use the type conversion functions to convert data from one data type to another. Listed below
are the type conversion functions available in the Conversion subnode of the Functions node in the
Expression Editor.

Function Description and Examples

CBool(x) Converts the expression used as the function argument into a Boolean expression. Re-
turns False if the Boolean value is 0; otherwise, returns True.

Example: CBool($CurrCompanyTot - $CompanyTot)

In this example, CurrCompanyTot and CompanyTot are report variables.

CDate(x) Converts the expression used as the function argument into a value of the Date type.
The argument should be a valid date expression according to the locale selected for the
import or export scenario.

Example: CDate($DueDate - 1)

In this example, DueDate is a report variable.

CStr(x) Converts the expression used as the function argument into a string. If the argument is
Null, the function returns a run-time error; otherwise, it returns a string.

Example: CStr($PrintDoc)

Here, PrintDoc is a report variable.

CDbl(x) Converts the expression defined in the function argument into a value of the Double
type.

Example: CDbl($CurrBal/$CurrTot)

Here, CurrBal and CurrTot are report variables.

CSng(x) Converts the expression used as the function argument into a value of the Single type.
If the expression has a value outside of the acceptable range for the Single type, this
function returns an error.

Example: CSng($StCycCurrTot/$CompanyTot)

In this example, StCycCurrTot and CompanyTot are report variables.
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Function Description and Examples

CDec(x) Converts the expression used as the function argument into a value of the Decimal
type.

Example: CDec($CompanyTot)

In this example, CompanyTot is a report variable.

CInt(x) Converts the expression used as the function argument into a value of the Integer type.

Example: CInt([ARPayment.ExtRefNbr])

In this example, ARPayment.ExtRefNbr is an attribute from the database scheme.

CShort(x) Converts a numeric value to a value of the Short type.

Example: CShort([ARPayment.ImpRefNbr])

ARPayment.ImpRefNbr is an attribute from the database scheme.

CLong(x) Converts a numeric value to a value of the Long type.

Example: CLong($CurrTot)

In this example, CurrTot is a report variable.

Aggregate Functions

Aggregate functions perform a calculation on a set of values and return a single value. Listed below are
the aggregate functions available in the Aggregates subnode of the Functions node in the Expression
Editor.

Function Description and Examples

Avg(expression) Returns the average of all non-null values of the specified expression.

Example: Avg($StCycAgeTot00, $StCycAgeTot01)

In this example, StCycAgeTot00 and StCycAgeTot01 are report variables.

Sum(expression) Returns the sum of the values of the specified expression.

Example: Sum([ARInvoice.TaxTotal], $CurrTot)

In this example, ARInvoice.TaxTotal is an attribute from the database scheme,
and CurrTot is a report variable.

Count(expres-
sion)

Returns the count of the values from the specified expression.

Example: Count($AgeBal00, $AgeBal01)

In this example, AgeBal00 and AgeBal01 are report variables.

Max(expression) Returns the maximum value from all non-null values of the specified expression.

Example: Max($CurrCompanyTot, $CompanyTot)

In this example, CurrCompanyTot and CompanyTot are report variables.
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Function Description and Examples

Min(expression) Returns the minimum value from all non-null values of the specified expression.

Example: Min($CurrCompanyTot, $CompanyTot)

In this example, CurrCompanyTot and CompanyTot are report variables.

Next(expression) Returns the next value (from the current one) in the specified expression.

Example: Next([ARInvoice.LineTotal],[ARInvoice.TaxTotal])

In this example, ARInvoice.LineTotal and ARInvoice.TaxTotal are attributes
from the database scheme.

Prev(expression) Returns the previous value (from the current one) in the specified expression.

Example: Prev([ARInvoice.LineTotal],[ARInvoice.TaxTotal]) ARIn-
voice.LineTotal and ARInvoice.TaxTotal are attributes from the database
scheme.

First(expres-
sion)

Returns the first value in the specified expression.

Example: First([ARInvoice.LineTotal],[ARInvoice.TaxTotal])

In this example, ARInvoice.LineTotal and ARInvoice.TaxTotal are attributes
from the database scheme.

Last(expression) Returns the last value in the specified expression.

Example: Last([ARInvoice.LineTotal],[ARInvoice.TaxTotal])

In this example, ARInvoice.LineTotal and ARInvoice.TaxTotal are attributes
from the database scheme.

String Functions

String functions perform an operation on a string input value and return a string or numeric value.
Listed below are the string functions available in the Text subnode of the Functions node in the
Expression Editor.

Function Description and Examples

LTrim(string) Removes all leading spaces or parsing characters from the specified character
expression, or all leading 0 bytes from the specified binary expression.

Example: LTrim(CStr([Contact.LastName]))

In this example, Contact.LastName is an attribute from the database
scheme.

RTrim(string) Removes all trailing spaces or parsing characters from the specified character
expression, or all trailing 0 bytes from the specified binary expression.

Example: RTrim(CStr([Contact.LastName]))

In this example, Contact.LastName is an attribute from the database
scheme.
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Function Description and Examples

Trim(string) Removes all trailing spaces or parsing characters from the specified character
expression, or all trailing 0 bytes from the specified binary expression.

Example: Trim(CStr([Contact.FirstName]+[Contact.MidName]+[Contac-
t.LastName]))

In this example, Contact.FirstName, Contact.MidName, and Contact.Last-
Name are attributes from the database scheme.

Format(format, argu-
ment(s))

Replaces the format item in the specified formatting string (format) with the
text equivalent of the arguments (arguments).

Example: Format('Curr. Balance: . . . . . . . . {0:N}; Total
Amount: . . . . . . . . {1:N}', $CurrBal, $CurrTot)

In this example, CurrBal and CurrBal are report variables; 0 and 1 are
specifiers indicating where the arguments will be inserted; C is the currency
format specifier; and N is the number format specifier.

UCase(string) Returns a string that has been converted to uppercase. The string argument
is any valid string expression. If string contains Null, Null is returned.

Example: UCase(CStr([RowContact.MidName]))

In this example, RowContact.MidName is an attribute from the database
scheme.

LCase(string) Returns a string that has been converted to lowercase. The string argument
is any valid string expression. If string contains Null, Null is returned.

Example: LCase(CStr([Contact.Email]))

In this example, Contact.Email is an attribute from the database scheme.

InStr(string, find-
String)

Returns the position of the first occurrence of one string (findString) within
another (string).

Example: InStr(CStr([Contact.Email]), '@')

In this example, Contact.Email is an attribute from the database scheme.

InStrRev(string,
findString)

Returns the position of the last occurrence of one string (findString) within
another (string), starting from the right side of the string.

Example: InStrRev(CStr([Contact.Email]), '@')

In this example, Contact.Email is an attribute from the database scheme.

Len(string) Returns an integer containing either the number of characters in the string or
the nominal number of bytes required to store a variable.

Example: Len(CStr([Contact.Email]))

In this example, Contact.Email is an attribute from the database scheme.
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Function Description and Examples

Left(string, length) Returns a string containing the specified number of characters from the left
side of a string. If string contains Null, Null is returned.

Example: Left(CStr([Contact.Email]), 7)

In this example, Contact.Email is an attribute from the database scheme.

Right(string,
length)

Returns a string containing the specified number of characters from the right
side of a string. If string contains Null, Null is returned.

Example: Right(CStr([Contact.Email]), 10)

In this example, Contact.Email is an attribute from the database scheme.

Replace(string, old-
Value, newValue)

Returns a string in which the specified substring (oldValue) has been re-
placed with another substring (newValue).

Example: Replace(CStr([Contact.Email]), '@.', '@')

In this example, Contact.Email is an attribute from the database scheme.

PadLeft(string,
width, paddingChar)

Right-aligns the characters in the specified string (string), padding with the
specified characters (paddingChar) on the left for the specified total width
(width).

Example: PadLeft(CStr([Contact.Email]), 7, '@')

In this example, Contact.Email is an attribute from the database scheme.

PadRight(string,
width, paddingChar)

Left-aligns the characters in the specified string (string), padding with the
specified characters (paddingChar) on the right for the specified total width
(width).

Example: PadRight(CStr([Contact.Email]), 10, '@')

In this example, Contact.Email is an attribute from the data scheme.

Substring(string,
start, length)

Returns a string containing the specified number of characters (length) from
the left side of the specified string (string) starting from the specified number
of symbols (start). The numbering is 0-based, meaning that the first charac-
ter in the string is 0.

Example: Substring([ARInvoice.DocDesc], 0, 10)

In this example, ARInvoice.DocDesc is an attribute from the data scheme.

Mathematical Functions

Mathematical functions perform calculations, usually based on input values provided as arguments, and
return numeric values. Listed below are the mathematical functions available in the Math subnode of
the Functions node in the Expression Editor.
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Function Description and Examples

Abs(x) Returns the absolute value of a number.

Example: Abs($CurrBal - $CurrTot)

In this example, CurrBal and CurrTot are the report variables.

Floor(x) Returns the largest integer that is not greater than the argument.

Example: Floor([Contact.NoteID])

In this example, Contact.NoteID is an attribute from the database scheme.

Ceiling(x) Returns the smallest integer that is not less than the argument.

Example: Ceiling([Contact.NoteID])

In this example, Contact.NoteID is an attribute from the database scheme.

Round(x, deci-
mals)

Returns a numeric expression, rounded to the specified precision (decimals).

Example: Round($CurrTot, 2)

In this example, CurrTot is a report variable.

Min(x, y) Returns the smaller of two values.

Example: Min($CurrTot, $CurrCompanyTot)

In this example, CurrTot and CurrCompanyTot are report variables.

Max(x, y) Returns the greater of two values.

Example: Max($CurrTot, $CurrCompanyTot)

In this example, CurrTot and CurrCompanyTot are report variables

Pow(x, power) Computes the value of x raised to the specified power (power).

Example: Pow(([Contact.NoteID], 2))

In this example, Contact.NoteID is an attribute from the database scheme.

Date and Time Functions

The date and time functions, described below, perform operations on input values and return values of
the following types: string, numeric, or date and time. Listed below are the string functions available in
the Date/Time subnode of the Functions node in the Expression Editor.
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Function Description and Examples

DateAdd(date, interval,
number)

Returns a new date, which is calculated by adding the specified number
(number) of time intervals (interval) to the date (date). The interval ar-
gument specifies the type of time interval and can be one of the follow-
ing options:

• y, yy, yyyy, or year: The specified number (number) of years will be
added to the specified date (date).

• m, mm, or month: The specified number (number) of months will be
added to the specified date (date).

• d, dd, or day: The specified number (number) of days will be added to
the specified date (date).

• h, hh, or hour: The specified number (number) of hours will be added
to the specified date (date).

• n, mi, or minute: The specified number (number) of minutes will be
added to the specified date (date).

• s, ss, or second: The specified number (number) of seconds will be
added to the specified date (date).

• w, ww, wk, or week: The specified number (number) of weeks will be
added to the specified date (date).

• q, qq, or quarter: The specified number (number) of quarters will be
added to the specified date (date).

Examples:

DateAdd($DueDate, 'm', -2)

DateAdd(CDate('31/01/1995'), 'm', -2)

DateAdd($DueDate, 'y', -2) DateAdd(Cdate($DueDate), 'd', -2)

In these examples, DueDate is a report variable.
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Function Description and Examples

DateDiff(interval,
date1, date2)

Returns the count (as a signed integer value) of the specified interval
boundaries crossed between the specified date1 and date2. The inter-
val argument, which specifies the type of time interval, can be one of the
following options:

• y, yy, yyyy, or year: The specified number (number) of years will be
added to the specified date (date).

• m, mm, or month: The specified number (number) of months will be
added to the specified date (date).

• d, dd, or day: The specified number (number) of days will be added to
the specified date (date).

• h, hh, or hour: The specified number (number) of hours will be added
to the specified date (date).

• n, mi, or minute: The specified number (number) of minutes will be
added to the specified date (date).

• s, ss, or second: The specified number (number) of seconds will be
added to the specified date (date).

• w, ww, wk, or week: The specified number (number) of weeks will be
added to the specified date (date).

• q, qq, or quarter: The specified number (number) of quarters will be
added to the specified date (date).

Day(date) Returns the day (as an integer) extracted from the specified date (date).

Examples:

Day([ARPayment.ClearDate])

Day($DueDate) Day(Cdate($DueDate))

Day(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

DayOfWeek(date) Returns the day of the week associated with the specified date (date) as
an integer.

Examples:

DayOfWeek([ARPayment.ClearDate])

DayOfWeek($DueDate)

DayOfWeek(Cdate($DueDate))

DayOfWeek(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.
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Function Description and Examples

DayOfYear(date) Returns the day of the year calculated for the specified date (date).

Examples:

DayOfYear([ARPayment.ClearDate])

DayOfYear($DueDate)

DayOfYear(Cdate($DueDate))

DayOfYear(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

DayOrdinal(day) Converts the specified integer value (day) to a string that contains the
ordinal number in the current locale. For example, for the English locale,
the string contains the short form of the ordinal number, such as 1st or
2nd. For numbers that are less than 1 or greater than 31, the function
returns an empty string.

Example: DayOrdinal(1)

Hour(date) Returns the number of hours extracted from the specified date (date).

Examples:

Hour([ARPayment.ClearDate])

Hour($DueDate)

Hour(Cdate($DueDate))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

Minute(date) Returns the number of minutes extracted from the specified date (date).

Examples:

Minute([ARPayment.ClearDate])

Minute($DueDate)

Minute(Cdate($DueDate))

Minute(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.
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Function Description and Examples

Month(date) Returns the month, as an integer, extracted from the specified date
(date).

Examples:

=Month([ARPayment.ClearDate])

=Month($DueDate) =Month(Cdate($DueDate))

=Month(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

MonthName(date) Returns a string that contains the name of the month extracted from the
specified date (date) in the current locale.

Example: MonthName(CDate('3/12/2018'))

Now() Returns the current date and time according to the system date and
time settings on the local computer.

Example: Now()

NowUTC() Returns the current date and time in the user's time zone. The system
extracts the user's time zone from one of the following sources, which
are ordered by priority from the highest to the lowest:

1. The time zone in the user's preferences, which is specified in the Time
Zone box on the General Info tab of the User Profile (SP203010)
form.

2. The employee calendar selected for the user in the Calendar box of
the General Info tab of the Employees (EP203000) form. Work calen-
dars are defined on the Work Calendar (CS209000) form.

3. The time zone in the site preferences, which is specified in the Login
Time Zone box on the Site Preferences (SM200505) form.

Example: NowUTC()

Second(date) Returns the seconds extracted from the specified date (date) as an inte-
ger.

Examples:

Second([ARPayment.ClearDate])

Second($DueDate) Second(Cdate($DueDate))

Second(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=8430c8b2-a79c-4f7b-9768-b0b7fad23a59
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=dae5144b-49b3-43a4-bce0-93f31b3f2321
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=9d01d650-0b68-4994-8146-c80fb5e34bbb
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4859a849-af09-420d-a55b-93c72eabd553


| Lesson 4: Using Variables and Expressions | 62

Function Description and Examples

Today() Returns the current date according to the system date and time settings
on the local computer.

Example: Today()

TodayUTC() Returns the current date in the user's time zone. The system extracts
the user's time zone from one of the following sources, which are or-
dered by priority from the highest to the lowest:

1. The time zone in the user's preferences, which is specified in the Time
Zone box on the General Info tab of the User Profile (SP203010)
form.

2. The employee calendar selected for the user in the Calendar box of
the General Info tab of the Employees (EP203000) form. Work calen-
dars are defined on the Work Calendar (CS209000) form.

3. The time zone in the site preferences, which are specified in the Login
Time Zone box on the Site Preferences (SM200505) form.

Example: TodayUTC()

Year(date) Returns the year, as an integer, extracted from the specified date
(date).

Examples:

Year([ARPayment.ClearDate])

Year(Cdate($DueDate)) Year($DueDate)

Year(CDate('31/01/1995'))

In these examples, DueDate is a report variable, and ARPayment.Clear-
Date is an attribute from the database scheme.

Shortcut Functions

The shortcut functions perform miscellaneous operations. Listed below are the string functions
available in the Math subnode of the Program Shortcut node in the Expression Editor.

Function Description and Examples

Assign('$name', expres-
sion)

Assigns the result of the expression calculation to the variable specified
as the parameter. The function can be used to assign a value to an ex-
isting variable, or a new variable can be created with the expression cal-
culation value assigned to it.

Example: Assign(PrintDoc, (IsNull([RowARRegister.Cus-
tomerID])))

In this example, PrintDoc is a report variable, and ARRegister.Cus-
tomerID is an attribute from the data scheme).

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=8430c8b2-a79c-4f7b-9768-b0b7fad23a59
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=dae5144b-49b3-43a4-bce0-93f31b3f2321
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=9d01d650-0b68-4994-8146-c80fb5e34bbb
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4859a849-af09-420d-a55b-93c72eabd553
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Function Description and Examples

Assign('$name', expres-
sion, resetExpression)

Assigns the result of the expression calculation to the variable specified
as the parameter. The expression value is assigned to the variable when
the variable is set, and the resetExpression value defines when the vari-
able value should be reset. The function can be used to assign a val-
ue to an existing variable, or a new variable can be created and the ex-
pression calculation value is assigned to it.

Example: Assign(<nowiki>'PrintDoc'</nowiki>, (IsNull([ARReg-
ister.CustomerID])), IsNull([APPayment.AdjFinPeriodID]))

In this example, PrintDoc is a report variable, and ARRegister.Cus-
tomerID is an attribute from the database scheme).

IIf(expression, truePart,
falsePart)

Returns one of two values, depending on the evaluation of the ex-
pression: If the expression evaluates to True, the function returns the
truePart value; otherwise, it returns the falsePart value.

Example: IIf(($CurrTot-$CurrBal)<>0), CStr([ARRegis-
ter.DocBal]), 'No data available')

In this example, CurrTot and CurrBal are report variables, and ARReg-
ister.DocBal is an attribute from the database scheme.

IsNull(value, nullValue) Returns nullValue if value is NULL; otherwise, returns value.

Example: IsNull($PrintDoc, 'NULL')

In this example, PrintDoc is a report variable.

NullIf(value1, value2) Returns NULL if value1 is equal to value2.

Switch(expression_1,
value_1, expression_2,
value_2, ...)

Returns the value (value_n) that corresponds to the first expression
(expression_n) that evaluates to True. expression_1, expression_2, and
so on are Boolean expressions.

Example: Switch((($CurrTot-$CurrBal)<0), $CurrBal, (($Cur-
rTot-$CurrBal)>0), $CurrTot)

In this example, CurrTot and CurrBal are report variables.

Application-Specific Functions

The application-specific functions are specific for the application in which you will run the report. That
is why these functions are not listed in the Expression Editor dialog box. You will need to enter these
functions manually.

The following table includes the application-specific functions available in Acumatica Report Designer.
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Function Description and Examples

GetAPPaymentInfo(ac-
countCD, paymentMethod-
ID, detailID, acctCD)

Returns the value of the specified AP payment attribute (detailID) for
specific cash account (accountCD), payment method (paymentMethod-
ID), and vendor (acctCD). The function returns the attribute value as it
is specified in the Payment Instructions section on the Payment Set-
tings tab of the Vendors (AP303000) form.

If the specified record is not available, the function returns an empty
string.

Example: Payments.GetAPPaymentInfo('102000','FED-
WIRE','INSTRUCTIONS','V000213')

GetARPaymentInfo(ac-
countCD, payment-
MethodID, detailID, pMIn-
stanceID)

Returns the value of the specified AR payment attribute (detailID) for
specific cash account (accountCD), payment method (paymentMethod-
ID), and customer (acctCD). The function returns the attribute value as
it is specified on the Payment Method Details tab of the Customer Pay-
ment Methods (AR303010) form.

If the specified record is not available, the function returns an empty
string.

Example: Payments.GetARPaymentInfo('102000','FEDWIRE','AC-
COUNTNO','C0003163')

GetRemitPaymentInfo(ac-
countCD, paymentMethod-
ID, detailID)

Returns the value of the specified payment attribute (detailID) for spe-
cific cash account (accountCD), payment method (paymentMethodID),
and vendor or customer (acctCD). The function returns the attribute
value as it is specified on the Remittance Settings tab of the Cash Ac-
counts (CA202000) form.

If the specified record is not available, the function returns an empty
string.

Example: Payments.GetRemitPaymentInfo('102000','FED-
WIRE','ACCOUNTNO')

Variables and Expressions: To Add a Variable and an
Expression

In the following activity, you will learn how to use variables and expressions in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager of your company has requested a report that displays data about vendors, so that
vendors are grouped by vendor class. In a class, vendors should be numbered. You know that your

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=a9584be3-f2bd-4d67-80d4-8041d809df56
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4293eea3-63d3-494e-8ee1-3d3f4a245ee1
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=4293eea3-63d3-494e-8ee1-3d3f4a245ee1
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=10f71454-88f9-4d6c-8d09-32856d8c6741
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=10f71454-88f9-4d6c-8d09-32856d8c6741
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colleague has created such a report, but without numbering. You decide to change the report that your
colleague has created.

Process Overview

In the Report Designer, you will open the AP6550C6 report, which is a modified copy of the Vendor 
Summary
(AP6550C6) report, and in the section in which vendors are listed, you will add two variables. One 
variable will calculate the visibility of a vendor. The second variable will calculate the sequential number 
of a vendor in the class and will be incremented by one for only the vendors that are visible.
System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C6.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C6 as the report name, and click OK.

The report is saved on the server.

Step 1: Adding Variables to a Report Section

To add variables to a section of the AP6550C6 report, do the following:

1. In the Report Designer, be sure the AP6550C6 report (which you have saved to the server) is
open.

2. Select the groupHeaderSection1 (Header of group1) section, and in the Behavior > Variables
property of the Properties tab on the Properties pane, click the  button.

The ReportVariable Collection Editor opens, where you can add variables to the report and define
their properties.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
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3. In the Members pane of the ReportVariable Collection Editor, click Add.

4. In the Misc > Name property on the right pane, type IsGroup1Visible to specify the name of the
variable.

5. In the Misc > ValueExpr property, click the  button.

The Expression Editor opens.

6. In the bottom pane of the Expression Editor, enter the following expression:
=IIF([@SupressZeroBal]=True AND Sum([APHistory.FinYtdBalance]) = 0, False, True)
AND IIF([@SupressInactiveVendors]=True AND [Vendor.Status] = 'I', False, True).

This is a visibility expression of groupHeaderSection1 (Header of group1). This expression is
true if summary balance of the vendor is not zero and the status of the vendor is not inactive.

You can type this expression in the bottom pane of the Expression Editor or you can compose
the expression by selecting necessary components from the left, middle, and right panes of the
Expression Editor. For example, you can select the IIf function under the Program Shortcuts
component type and the @SupressInactiveVendors parameter in the middle pane. You can select
DAC fields in the left pane. After you have constructed the expression, you can validate it by
clicking the Validate button.

7. Click OK to close the Expression Editor.

8. In the Members pane of the ReportVariable Collection Editor, click Add.

9. In the Misc > Name property on the right pane, type Num to specify the name of the second
variable.

10. In the Misc > ProcessOrder property, leave the default value—that is, WhileRead. This value
directs the system to process the values of variables while reading these variables.

11. In the Misc > ResetGroup property, select NewGroup to reset the value of the Num variable.

This means that in the NewGroup group, the variable should be calculated locally. If you have set
this property, for each instance of the specified group, the variable has an independent value. At
the end of each group, the variable is reset.

12. In the Misc > ValueExpr property, type =$Num + IIF($IsGroup1Visible, 1, 0).

This means that the value of the Num variable will be incremented by one only if the
IsGroup1Visible variable is true.

As with the IsGroup1Visible variable, you can compose the expression in the Expression Editor.

Notice that you have specified IsGroup1Visible first and Num second because the Num value is
calculated by using the IsGroup1Visible value.

13. Click OK to save your changes and close the ReportVariable Collection Editor.

14. On the Report Designer window toolbar, click Save.

The following screenshot shows the variables added to groupHeaderSection1 (Header of group1).
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Figure: Variables in the ReportVariables Collection Editor

Step 2: Adding a Text Box to Display Numbers

To add a text box to display numbers, while you are still working with the AP6550C6 report in the
Report Designer, do the following:

1. From the Tools pane, drag the TextBox element to groupHeaderSection1 (Header of group1),
to the left, and enter the =$Num value for the added text box.

2. While the text box is selected, in the Appearance > StyleName property on the Properties tab,
type Normal to set a uniform style for text boxes in the section.

3. On the Report Designer window toolbar, click Save to save the report on the server.

The report in design mode is shown in the following screenshot.

Figure: Report in design mode

Step 3: Viewing the Report

To view the report, do the following:
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1. In Acumatica ERP, open the Vendor Summary (AP6550C6) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the report form toolbar, click Run Report.

The resulting report is shown in the following screenshot.

Figure: The Vendor Summary (AP6550C6) report with vendors numbered in each vendor class

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Lesson 5: Using Parameters and Filters

Parameters and Filters: General Information

In the Acumatica Report Designer, you can define parameters for the report you are designing, and
users will specify the values for these parameters before they run the resulting report. For the report,
you also can specify the filtering conditions, which determine the data to be retrieved.

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Specify parameters in a report

• Set up filters in a report

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You want to modify an existing report to filter data, or add or modify parameters that users can
select to view data that meets their current needs.

Parameters

Report parameters are variables that the user specifies on the report form before running the report.
You can use parameters to share values between two or more reports, or in expressions and formulas
to calculate values for multiple fields within the same report. Based on the parameter, the report
engine creates a variable within the report, which can be referred to as a database field can. When a
parameter is referred to in code, it starts with the @ symbol.

If you have defined parameters for a report in the Report Designer, then these parameters are
displayed on the Report Parameters tab of the report form in Acumatica ERP.

You can specify parameters for a report on the Parameters tab of the Schema Builder. You add a
parameter by clicking the Add button (lower left) and specifying the following settings:

• Name (required): The name that you assign to the parameter.

• Data Type (required): The data type of the parameter. You can select one of the following types
from the drop-down list: Boolean, Date time, Float, Integer, and String.

• Prompt: The title that is displayed left to the parameter on the Report Parameters tab of
the report form in Acumatica ERP. If this value is not specified, the prompt and the box for
specification of the parameter will not be displayed and a user will not be able to enter or select
any value, but you can use this hidden parameter

• Default Value: The value of the parameter when the user opens the report form; this value is
used by default if a user does not specify another value. While designing and debugging a report
in the Report Designer, you can experiment specifying different values. In the final version of the
report, specify the preferred value or leave the setting empty.
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• Input Mask: The input mask to be used for entering the data for the parameter. For example, you
can specify an input mask for a telephone number. You can specify a formula in the Expression
Editor to define the input mask.

• View Name: The lookup window that will open to help the user running the report select the
parameter. Usually, in the View Name box, the Report.GetFieldSchema(DAC.field) function is
selected. This function returns a detailed description of the lookup window depending upon the
specified DAC and field. The lookup window contains all the possible values of the parameter from
which the user running the report can select the necessary value.

You can also use any field of any existing outside DAC if it has an attribute with
appropriate lookup columns for the report parameter being adjusted. You can create a
special DAC with the needed lookup fields if you haven’t found the appropriate field or
fields in the existing DACs.

• Column Span: The column span to be used to display the parameter on the report form. The
default column span is 1, indicating that the parameter occupies two columns.

• Allow Null: A check box that specifies whether the parameter can be null. By default, the check
box is cleared, which means that the parameter cannot be null. If you select the check box, the
parameter can be null.

• Visible: A check box that indicates whether the parameter will be visible. By default, the
check box is selected. If you clear the check box, the parameter will not appear on the Report
Parameters tab of the report form and will be used only internally.

• Required: A check box that you use to specify whether the parameter is required to run the
report. By default, the check box is cleared, which means that a user can run the report without
specifying a value for the parameter. If you select the check box, a user cannot run the report
without specifying a value for this parameter.

• Available Values: A table in which you can specify the values that a user can select in the box of
the parameter on the report form.

To delete any parameter from the list on the Parameters tab of the Schema Builder by clicking the
parameter in the left pane and then clicking the Remove button.

Acumatica ERP has the following predefined date-relative parameters:

• @Today: The current day.

• @WeekStart and @WeekEnd: The start and end, respectively, of the current week. The start and
end of the week are determined according to the default system locale or the locale the user has
selected when signing in to Acumatica ERP. The system locales are specified and configured on the
System Locales (SM200550) form.

• @MonthStart and @MonthEnd: The start and end, respectively, of the current month.

• @QuarterStart and @QuarterEnd: The start and end, respectively, of the current quarter.

• @PeriodStart and @PeriodEnd: The start and end, respectively, of the current financial period. The
financial periods are defined on the Financial Year (GL101000) form.

For more information on financial periods in Acumatica ERP, see Managing Financial Periods in the
Acumatica ERP Financial Management Guide.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=6b40927b-3288-4ccd-bd7f-786fb246b9ac
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=9d9ad167-c686-482b-985f-f48dd79cfca1
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=96e30f1d-3948-4405-aa90-8afdbaccd06a
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• @YearStart and @YearEnd: The start and end, respectively, of the current calendar year.

All the date-relative parameters use the date (in UTC) of the server used to run the
Acumatica ERP instance as the current date.

Filters

You can use filters to limit the volume of data selected for the reports, specify more specific criteria for
selecting data from data tables, and remove unnecessary data as a result of the table joining. When
you define filters, you can use parameters. Filters are transformed to the SQL WHERE clause.

You can specify filters in the following ways:

• On the Filters tab of the Schema Builder.

• In the FilterExp Collection Editor (that is, the FilterExp Collection Editor dialog box). You use
the Data > Filters property in the Properties pane of the Properties tab to open the FilterExp
Collection Editor.

Filter expressions use the data field names and parameters to specify the criteria for data processing.
You specify filters as one filter clause or multiple filter clauses. For each clause, you specify the
following settings:

• Data Field: A data field or parameter that you select from the list.

• Condition: The logical operation that applies to the value of the selected property. You select a
condition from the list of available conditions.

• Value 1 (and Value 2, if needed): A value for the logical condition that is used to filter the data.
Depending on the selected property and condition, you enter one value or two values. Each value
must conform with the data type of the selected property. You can use parameters for value
settings.

Not all conditions require you to specify values. For example, values are not necessary for the Is
Null and IsNotNull conditions.

You can use And and Or operators and parentheses to group clauses into logical expressions.
Parentheses can be used in logical statements to define the order of operations. The And and Or
operators work on a unit in parentheses as if the unit was a single clause.

Any defined expression can be deleted. You can delete an expression in the following ways:

• In the Schema Builder, by clicking the row with the filter you want to delete and pressing the
DELETE key.

• In the FilterExp Collection Editor, by clicking the row with the filter you want to delete and then
clicking the Remove button (or pressing the Delete key).

Parameters and Filters: To Specify Parameters

In the following activity, you will learn how to define parameters for a report.
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The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager of your company has requested a report that displays data about vendors. You have
offered the predefined Vendor Summary (AP655000) report, but the sales manager has asked you
to give report users the ability to specify a vendor class. You will perform preliminary work before
realizing the ability to view the report for a selected vendor class.

Process Overview

In the Report Designer you will open the AP6550C2 report, which is a copy of the Vendor Summary 
(AP655000) report. In the Schema Builder, on the Tables tab, you will look for the field that 
contains the vendor class; you will need this field to specify the parameter. You will add a new 
parameter on the Parameters tab.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C2.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C2 as the report name, and click OK.

The report is saved on the server.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
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Step 1: Defining the Parameter for the Report

To define the parameter for the vendor class in the AP6550C2 report, do the following:

1. In the Report Designer, be sure the AP6550C2 report (which you have saved to the server) is
open.

2. On the Report Designer menu bar, click File > Build Schema to open the Schema Builder.

3. On the Parameters tab, click the Add button.

A new parameter is added to the list of parameters.

4. In the Name box, enter the parameter name as follows: Class.

5. In the Data Type box, select String.

6. In the Prompt box, enter the prompt for the parameter as follows: Vendor Class.

7. In the Default Value box, enter the default value for the parameter. You can use expressions and
formulas to define parameters' default values.

8. In the Column Span box, set the value to 2.

9. Select the Allow Null and Visible check boxes.

10. Clear the Required check box.

11. In the View Name box, click the  button, and in the window that opens, enter the formula used
to retrieve data for the parameter from the Vendor data access class and the VendorClassID data
field as follows: =Report.GetFieldSchema('Vendor.VendorClassID').
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Figure: Class parameter on the Parameters tab

12. Click the Apply button.

13. Click OK to save the parameters defined for the report and close the Schema Builder.

14. On the Report Designer window toolbar, click Save.

Step 2: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Vendor Summary (AP6550C2) report form by searching for its
identifier.

On the Report Parameters tab, notice that the Vendor Class label is displayed left of the box
with the defined parameter.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. In the Vendor Class box, select any value.

3. On the report form toolbar, click Run Report.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Make sure that the report contains vendors of all classes, regardless of the class that you have
specified. The report is shown in the following screenshot.

Figure: The Vendor Summary (AP6550C2) report with the added parameter for the vendor class

Parameters and Filters: To Define Filters

In the following activity, you will learn how to define filters for data in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager of your company has requested a report that displays data about vendors. You have
offered the predefined Vendor Summary (AP655000) report, but the sales manager has asked you
to give report users the ability to view the report for a selected vendor class. If no vendor class is
specified, the report should display the full list of vendors.

Process Overview

In the Report Designer, you will open the AP6550C3 report, which is a modified copy of the Vendor 
Summary (AP655000) report. In the Schema Builder, on the Filters tab, you will add clauses to limit 
the data in the report. With this filter, the report will display only documents that fall within the 
specified range of financial periods.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
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• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C3.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C3 as the report name, and click OK.

The report is saved on the server.

Step 1: Defining the Filter

To define the filter for the vendor class in the AP6550C3 report, do the following:

1. In the Report Designer, be sure the AP6550C3 report (which you have saved to the server) is
open.

2. On the Report Designer menu bar, click File > Build Schema to open the Schema Builder.

3. On the Filters tab, in the table, add two filter clauses. The first clause uses the @Class parameter
specified in this report. It means that the value in the Vendor.VendorClassID field will be compared
with the value of the vendor class that a user will specify before running the report. Specify the
following settings in the first row of the table:

• Data Field: Vendor.VendorClassID

• Condition: Equal

• Value 1: @Class

• Operator: Or

The second clause covers the case when a user will not specify a vendor class before running the
report. Specify the following settings in the second row of the table as follows:

• Data Field: @Class

• Condition: IsNull

These two clauses are grouped into one expression by the Or operator, which is why the first row
contains this operator.
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Figure: Adding the filter

4. Click the Apply button.

5. Click OK to save the filter defined for the report and close the Schema Builder.

6. On the Report Designer window toolbar, click Save.

Step 2: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Vendor Summary (AP6550C3) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the Report Parameters tab, in the Vendor Class box, select any value, for example, Product.

3. On the report form toolbar, click Run Report.

Make sure that the report contains only vendors of the class you have specified. The following
screenshot displays the report generated for the Product vendor class.

Figure: The Vendor Summary (AP6550C3) report for the Product vendor class

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Lesson 6: Sorting and Grouping Data

Data Sorting and Grouping: General Information

As you define a report by using the Acumatica Report Designer, you can divide the data into groups,
each of which displays the sorted data in the order selected for the group. The sorting criteria are
defined separately for every report group and for the report as a whole.

To set up the data grouping and sorting rules, you should define the following:

• The data groups to be included in the report and their sorting rules

• The data sorting rules for the report

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Create data groups in a report

• Specify sorting criteria for the data in a report group and the data in a report

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• Your colleagues have asked you to group and sort the data in reports.

Data Grouping

Data groups are used to structure and logically group data in a report. You can add new data groups to
the report and define the behavior properties for each group. The groups' data will be displayed on the
pages of the generated report. For example, you may want to group sales orders by date and status to
get the count of sales orders.

By defining data groups in a report, you specify the grouping conditions for the SQL request that is
generated by the report.

You define data groups in the Properties pane of the Report Designer, on the Properties tab. You
use the Data > Groups property to open the Group Collection Editor (that is, the Group Collection
Editor dialog box), where you can specify the names of groups and their properties.

The Data property is available only if the report is selected, but none of its elements, such
as a section, is selected. An indicator of the selected report is the  icon at the top left
corner of the Design pane of the Report Designer.

When you create a data group, its header and footer sections are added to the report layout, which
is displayed in the Design pane of the Report Designer: The header section of the group is placed
between the header section of the page and the detail section; the footer section of the group is placed
between the detail section and the footer section of the page. If your report already has data groups
and you add a new group, the header section and the footer section of the new group are inserted
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inside the header section and the footer section of the last created group. The order of groups is
defined in the Group Collection Editor, where you can change the order of the groups in the report by
using the buttons with the arrow icons.

Data Sorting

You can specify how the data in a report is sorted. If you have defined data groups in the report, the
data in the groups is initially sorted according to the sorting rules (if they are specified) of the defined
group, and then the data of the detail section is sorted according to the sorting rules (if they are
specified) of the report.

By defining the sort order, you specify an ORDER BY clause for the SQL statement that is generated by
the report.

If you need to sort data, you should select the object for sorting—that is, the group or a report. By
default, a sort order is not specified for the detail section. You define the sort order of the data in a
group or in a report in the Properties pane of the Report Designer, on the Properties tab. Depending
on the object for sorting, you use the following properties:

• Data > Sorting: You use this property to sort the data in the detail section of the report. By
clicking the  button next to the property, you open the SortExp Collection Editor and specify the
necessary sort order.

• Data > Groups: You use this property to sort the data in the group. By clicking the  button next
to the property, you open the Group Collection Editor, in which you select the group whose data
you want to sort. For the Behavior > Grouping property of the selected group, you open the
GroupExp Collection Editor, and specify the values for the DataField and SortOrder properties.

In the Schema Builder, on the Sorting and Grouping tab, you can view the settings that are specified
for grouping and sorting. You can also change and define the sort order for existing groups.

Data Sorting and Grouping: To Specify Data Group in a
Report

In the following activity, you will specify a data group in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on customizations. A
sales manager of your company has requested a report that displays data about vendors. You have
offered the predefined Vendor Summary (AP655000) report, but the sales manager wants the data to be
grouped by vendor class. The sales manager has also asked you to display the total balance for each
group. You will create the requested report by using a copy of the Vendor Summary report.

Process Overview

In the Report Designer, you will open the AP6550C1 report, which is a copy of the Vendor Summary 
(AP655000) report, and add a new group. You will specify a grouping condition and other properties 
for the new 

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
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group. You will then modify report layout and place necessary elements to the new group. Then in the
Schema Builder, on the Sorting and Grouping tab, you will review the changes that you have made
on the Properties tab of the Properties pane.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C1.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C1 as the report name, and click OK.

The report is saved on the server.

Step 1: Creating a Group in the Report

To create the group in the AP6550C1 report, perform the following steps:

1. In the Report Designer, be sure the AP6550C1 report (which you have saved to the server) is
open.

2. In the top left corner of the Design pane, click the  icon to select the whole report as an object.

3. On the Properties tab of the Properties pane, in the Data > Groups property, click the  button.

4. In the Group Collection Editor, which opens, in the Members pane on the left, click Add.

A new group with the default group2 name is added and displayed in the Members pane.

5. Click OK to save the new group and close the Group Collection Editor.

On the report layout, notice that the new group is placed inside the existing group1.
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Step 2: Specifying the Properties of the Group

To specify the group properties, while you are still working with the AP6550C1 report in the Report
Designer, do the following:

1. In the top left corner of the Report Designer screen, click the  icon to select the whole report as
an object.

2. On the Properties tab of the Properties pane, in the Data > Groups property, click the  button.

3. In the Group Collection Editor window, which opens, in the Members pane, select group2.

4. By the button with the arrow pointing upward, place group2 at the top of the list.

The order of the groups in the Group Collection Editor defines the order of groups in the report.

5. In the group2 properties pane on the right of the Group Collection Editor, in the Design >
(Name) property, type NewGroup.

6. Select the Behavior > Grouping property, and click the  button.

7. In the GroupExp Collection Editor, which opens, in the Members pane, click Add.

8. In the PX.Reports.GroupExp properties pane, in the Misc > DataField property, type
Vendor.VendorClassID to specify the grouping condition based on the class of a vendor.

By clicking the  button right of the Misc > DataField collection, you can invoke the
Expression Editor. In the left pane, you can select the necessary field from the list.

Notice that the Misc > SortOrder property has the Ascending value, which means that by default,
the data in the group is sorted in ascending order.

9. Click OK to save your changes and close the GroupExp Collection Editor.

10. Click OK to close the Group Collection Editor.

Step 3: Placing Elements in the New Group

To place elements in the new group, while you are still working with the AP6550C1 report in the Report
Designer, do the following:

1. In the Design pane of Report Designer, in the pageHeaderSection2 section, select the text box
with the Class value and move it to the groupHeaderSection2 (Header of NewGroup) section (to
the left).

2. In the groupHeaderSection1 (Header of group1) section, select the text box with the
=[Vendor.VendorClassID] value, and move it to the groupHeaderSection2 (Header of
NewGroup) section right of the text box with the Class value.

3. Adjust the height of the groupHeaderSection2 (Header of NewGroup) section to be the same as
the height of the text boxes in the section.



| Lesson 6: Sorting and Grouping Data | 82

You can also adjust the height of the groupHeaderSection2 (Header of NewGroup)
section on the Properties tab of the Properties pane. Select groupHeaderSection2
(Header of NewGroup), and for the Appearance > Height property, type the value as
follows: 20px.

4. In the groupHeaderSection1 (Header of group1) section, copy the text box with the following
value: =sum([APHistory.FinYtdBalance]); and paste the text box in the groupFooterSection2
(Footer of NewGroup) section, in the column with the Current Balance title. This element will
display the total balance for the members of the NewGroup group.

5. Adjust the height of the groupFooterSection2 (Footer of NewGroup) section to be the same as
the height of the text box in the section.

6. In the Report Designer window toolbar, select Save.

7. Click the Preview tab to preview the report.

Make sure that the data of one group is displayed.

Step 4: Reviewing the Sorting and Grouping Settings in the Schema Builder

While you are still working with the AP6550C1 report in the Report Designer, in the Report Designer,
click File > Build Schema. In the Schema Builder, which opens, go to the Sorting and Grouping
tab. Make sure that the settings on this tab are the same as those that you have specified in the
Properties pane of the Report Designer. The settings are shown in the following screenshot.

Figure: Grouping and sorting settings for the AP6550C1 report

Step 5: Viewing the Report

In Acumatica ERP, open the Vendor Summary (AP6550C1) report form by searching for its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can access it
in Acumatica ERP.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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On the report form toolbar, click Run Report. Notice that the data in the report is grouped by vendor
class and that a total balance is displayed for each class. The following screenshot shows the report.

Figure: The Vendor Summary (AP6550C1) report, with data grouped by vendor class

Data Sorting and Grouping: To Specify Sorting
Conditions

In the following activity, you will specify the sort order for the data in a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on customizations. An
accountant of your company has requested a report that displays the AP batch register. You have
offered the predefined AP Batch Register Detailed (AP621000) report, but the sales manager has
requested that the data be sorted by batch number in descending order and by stock item description
in ascending order.

Process Overview

In the Report Designer, you will open the AP6210C1 report, which is a copy of the AR Batch Register 
Detailed (AP621000) report. Then you will find the sections of the data for sorting. You will add the 
sorting condition for the data in detailSection1 and change the sort order in the existing group1 
group. In the Schema Builder, on the Sorting and Grouping tab, you will review the changes that you 
have made in the Properties pane, on the Properties tab.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=c7f39b83-89d6-477b-a233-7ff8fdd84582
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=718d2bcb-c4c0-4f69-a08e-428665cb77dd
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2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6210C1.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6210C1 as the report name, and click OK.

The report is saved on the server.

Step 1 (Optional): Looking for the Report Sections of the Data for Sorting

This step is not required if you understand in which sections the data for sorting is located.

To find the sections in which the needed data—that is, the batch number and stock item description—is
placed, do the following:

1. In the Report Designer, be sure the AP6210C1 report (which you have saved to the server) is
open.

2. Select groupHeaderSection1 (Header of group1), and in the Appearance > Style >
BackColor property, select the light green color.

3. Repeat the action described in the previous instruction twice: First select the light yellow color for
detailSection1, and then select the light turquoise color for detailSection2.

For each section, you can use a color that you prefer. The only requirement is that color
for each section must be different.

4. On the Report Designer menu bar, click File > Save To Server, which opens the Save Report on
Server dialog box.

5. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, enter AP6210C1 as report name, and click OK.

The report is saved on the server.

6. In Acumatica ERP, open the AP Batch Register Detailed (AP6210C1) report form by searching for
its identifier.
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This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

7. On the report form toolbar, click Run Report.

Notice that different sections of the report have different colors. The stock item description has
a yellow background because it is located in detailSection1. The batch number has a green
background because it is located in group1. Based on this information, you can make a conclusion
about the sections in which you need to sort data. You will need to sort data in the group1 group
by batch number (the Batch.BatchNbr field) and in the detailSection1 section by stock item
description (GLTran.TranDesc field).

Step 2: Specifying the Sort Order for the Data Group

To specify sort order for the group1 data group, do the following:

1. While you are viewing the AP6210C1 report in the Report Designer, in the top left corner of the
Design pane, click the  icon.

2. In the Properties pane, right of the Data > Groups property, click the  button.

3. In the Group Collection Editor, which opens, in the Members pane, click the group, and in the
right pane, right of the Behavior > Grouping property, click the  button.

4. In the GroupExp Collection Editor, which that opens, in the Members pane, select the second
member (its Misc > DataField property is Batch.BatchNbr). In the Misc > SortOrder property,
select Descending.

5. Click OK to save your changes and close the GroupExp Collection Editor.

6. Click OK to close the Group Collection Editor.

Step 3: Specifying the Sort Order for the Report Data

To specify the sort order for the data in the report, while you are still working with the AP6210C1
report in the Report Designer, do the following:

1. In the top left corner of the Design pane, click the  icon to select the report.

2. In the Properties pane, right of the Data > Sorting property, click the  button.

3. In the SortExp Collection Editor, which opens, click the Add button to add the new criteria for
sorting.

4. In the right pane of the SortExp Collection Editor, in the Misc > DataField property, select
GLTran.TranDesc. This field will be used to sort the data in the report.

5. In the Misc > SortOrder property, select Ascending.

6. Click OK to save your changes and close the SortExp Collection Editor.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Step 4: Reviewing the Sorting and Grouping Settings in the Schema Builder

While you are still working with the AP6210C1 report in the Report Designer, click File > Build
Schema. In the Schema Builder, which that opens, select the Sorting And Grouping tab. Make sure
that the settings on this tab are the same as those that you have specified in the Properties pane of
Report Designer. The settings in the Schema Builder are shown in the following screenshot.

Figure: Sorting and grouping settings for the AP6210C1 report in the Schema Builder

Step 5: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the AP Batch Register Detailed (AP6210C1) report form by searching for
its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the Report Parameters tab, in the From Period box, select 01-2020, and in the To Period
box, select 12-2020.

3. On the report form toolbar, click Run Report.

Make sure that the report is sorted by batch number in descending order and by stock item description
in a batch in ascending order. The following screenshot displays one of the report pages.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Figure: Sample page of the AP Batch Register Detailed (AP6210C1) report
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Lesson 7: Modifying the Report Style

Report Style: General Information

Each company has its own style for the design of documents, letterheads, and reports. Adhering to
the adopted design in your company, you can make a uniform style for Acumatica ERP reports in your
company. For this purpose, in the Acumatica Report Designer, you can specify styles for individual
elements or apply style templates to the reports that you design and modify.

Learning Objectives

In this chapter, you will learn how to do the following in the Report Designer:

• Change the style of an element in a report

• Change the style of number of reports

Applicable Scenarios

You may want to use the Acumatica Report Designer in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to change the style of one element or a group of elements in a report, or apply a uniform
style to a number of reports in the system.

Ways to Change the Style of Elements in Reports

Depending on the type of an element in a report, the style of the element can include a number of
settings. A report primarily includes text boxes. The style of a text box defines the text font (type,
style, and color), text alignment, and background color. In a new report, all elements that you add to
the report layout are assigned the default style. You can change the style of elements in a report in the
following ways:

• By specifying the style of an individual element. You can perform this action in the Appearance >
Style group of properties.

This way of changing the style can be very time-consuming, because you need to configure the
style of each element in a report. Usually you combine this way with other ways.

• By selecting a predefined style for an element. You can perform this action in the Appearance >
StyleName property.

The list of styles in the Appearance > StyleName property includes the collection of styles
specified in the Appearance > StyleSheet property of the report and the collection of styles
specified in the style template if one has been applied to the report. If a collection of styles or a
style template has not been specified in the report, you cannot use this way (selecting a predefined
style for an element)to change the style of elements in the report.

Selecting a predefined style for an element gives you the ability to manage a style of multiple
elements in a report in one action.
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• By specifying a style template for the report. You can perform this action by using the
Appearance > StylesTemplate property. For more detail about style templates, see the Style
Templates for Reports in the Report Designer section below.

In a new report, no style template is specified.

Creation of a Collection of Styles

In the Report Designer, you can create a collection of styles for a particular report. Later, you can use
styles from both collections—the collection you have specified for the report and the collection of styles
that is specified in a style template applied to the report.

You create a collection of styles by using the Appearance > StyleSheet property. This property
presents a collection of styles of different types of elements. After you have specified a collection of
styles, you can select an element in the report; in the Appearance > StyleName property, you apply
the style from the collection to the selected element.

You add members to a collection of styles in the StyleRule Collection Editor. Then for each member, you
specify its properties in the Style Builder.

In the collection of styles, you can specify multiple members dedicated to the same type of report
element. For example, you can specify members for the text boxes that display the following:

• Report heading

• Table heading

• Data in a report and table content

• Counted data in the Total rows

A new report does not have a collection of styles.

Style Templates for Reports in the Report Designer

The use of a style template is the preferred way to change the style of elements in a report. A style
template gives you the ability to specify uniform settings for elements not only in one report but also in
a number of reports. A style template includes the collection of styles specified in the Appearance >
StyleSheet property. A style template is a file with the RPX extension, as other report files are.

Acumatica ERP has the following predefined style templates, which are stored in the Site/
ReportsDefault folder and on the server:

• TemplateReport.rpx: Intended for reports for general purposes

• TemplateForm.rpx: Intended for printable reports

You can use the existing style templates, as well as define your own custom style templates. To define
a custom style template, in the Report Designer, you do the following:

1. You create a new report.

2. You select the report form.

3. You specify style collection in the Appearance > StyleSheet property.

4. You save this report locally or on the server.
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Then you can use this report as a style template.

You apply a style template as follows:

1. You select a report—that is, in the Properties pane of the Report Designer, on the Properties tab,
you select the report1 Report option.

2. As the value of the Appearance > StylesTemplate property, you enter (if you want to use a
style template from the server) or select (if you want to use a style template from local folder) the
name of the style template file.

After you have specified a style template for a report, in the Appearance > StyleName property, you
can select predefined styles of elements defined in the Appearance > StyleSheet property of the
style template file.

The Appearance > StyleSheet property of the report that you design does not inherit the
settings of the same property of the style template file.

Report Style: To Create and Apply a Style Template

In the following activity, you will learn how to create a style template and apply it to a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
An accountant has asked you to implement new company standards for the reports in the Payables
workspace. The standards are the following:

• Reports must have a light-blue background.

• For report titles, the following font must be used:

• Type: Bold

• Style: New Times Roman

• Size: 12 px

• Color: Blue

• For report parameters, the following font must be used:

• Type: Italic

• Style: Arial

• Size: 10 px

• Color: Black
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You have decided to create a new style template based on the new standards. Then you can apply this
style template to the reports in the Payables workspace.

Process Overview

In the Report Designer, you will create a new style template. In a new report, in the Appearance >
StyleSheet property, you will create a collection of styles in line with the accountant's requirements.
You will save the new report as TemplateForPayables.rpx. Then you will apply this style template to 
the AP6325C1 report, which is a copy of the AP Balance by Vendor (AP632500) report.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6325C1.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6325C1 as the report name, and click OK.

The report is saved on the server.

Step 1: Creating a New Style Template

To create a new style template, do the following:

1. In the Report Designer, click File > New to create a new file.

2. In the Properties pane, right of the Appearance > StyleSheet property, click the  button.

3. In the lower left of the StyleRule Collection Editor, which opens, click Add.

A new member, PX.Reports.Drawing.StyleRule, is added to the Members pane.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=0d1c7f3f-90d6-4d12-894f-05fadf489921
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4. In the right pane, specify the properties of the new added member as follows:

• Name: Type ReportTitle.

• Style: Click the  button to open the Style Builder, click Text on the left, and specify the
following settings:

• Name: Times New Roman

• Size: 12 px

• Bold: Selected

• Color: Blue

Click OK to close the Style Builder.

5. Repeat the actions of Instructions 3 and 4, and add two more members in the StyleRule Collection
Editor (see the screenshot below).

For the member named Parameters, in the Style Builder, click Text on the left and specify the
following style settings:

• Name: Arial

• Size: 10 px

• Italic: Selected

• Color: Black

For the member named Background, in the Style Builder, click Background on the left and type
#EAF4F4 in the Color box.

6. Click OK to close the StyleRule Collection Editor.

7. Click File > Save To Server, which opens the Save Report on Server dialog box.

8. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, enter TemplateForPayables.rpx name as the report name, and click OK.

The report is saved on the server.
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Figure: The list of styles specified in the StyleRule Collection Editor

Step 2: Applying the Style Template to the Report

To apply the customized template to the AP6325C1 report, do the following:

1. In the Report Designer, be sure the AP6325C1 report (which you have saved to the server) is
open.

2. In the top left corner of the Design pane, click the  icon to select the report.

3. On the Properties tab of the Properties pane, in the Appearance > StylesTemplate property,
type TemplateForPayables.rpx.

4. Click the text box with the report title (in the upper left of the report), and in the Appearance >
StyleName property of the Properties pane, select ReportTitle, which is the name of the style
that you have defined in the TemplateForPayables template.

5. Select two text boxes below the box with the report title (Company/Branch: =[@OrgBAccountID])
and three text boxes to the right of the report title (=Report.ExtToUI('Batch.FinPeriodID',
@PeriodID), =[@VendorID], Include Applications), and in the Appearance > StyleName
property of the Properties tab, select Parameters. This is the name of the style that you have
defined in the TemplateForPayables template.

To select multiple text boxes, you first click one text box, then push and hold Ctrl key
and click the rest text boxes.
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6. In the top left corner of the Design pane of Report Designer, click the  icon to select the report.
On the Properties tab of the Properties pane, in the Appearance > StyleName property,
select Background, the name of the style that you have defined in the TemplateForPayables style
template.

7. On the Report Designer window toolbar, click Save.

Step 3: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the AP Balance by Vendor (AP6325C1) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. In the Financial Period box of the Report Parameters tab, leave the default value or select
12-2020.

3. Click Run Report.

Make sure that the report has a light-blue background, the title has the Times New Roman blue bold
font (with a size of 12 pixels), and the report parameters have the Arial black italic font (with a size
of 10 pixels). The following screenshot shows the report with the applied TemplateForPayables style
template.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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Figure: The AP Balance by Vendor (AP6325C1) report with the new style template applied
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Lesson 8: Developing Tabular Reports

Tabular Reports: General Information

Tabular reports display data in a series of columns, with the column headers displayed directly above
the columns, and rows. This form of data presentation gives you the ability to compare and analyze
data in one report. For example, you may need to analyze sales data by financial periods or by sales
managers. By using the Acumatica Report Designer, you can configure tabular reports.

Learning Objectives

In this chapter, you will learn how to create tabular reports in the Report Designer.

Applicable Scenarios

You may want to create tabular reports by using the Acumatica Report Designer in the following
circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to create tabular reports, to compare and analyze the same type of data according to a
given criteria.

Examples of Tabular Reports

You can use a tabular report, for example, to view a breakdown of your sales by salesperson and
inventory item. In this case, the rows would show salespersons' names, the columns would display
inventory item names, and the cell at the intersection of each row and column would contain the total
sales amount of the item for the particular salesperson.

Another example of a tabular report is a report that displays sales by month. In this case, the rows
would display the item names, the columns would show the months, and the cell at the intersection of
each row and column would contain the total sales amount of the item in the month.

Configuration of a Tabular Report

To configure a tabular report, in the Report Designer, you need to specify the following properties for
the report:

• Data > Groups: In your report, you need to have a group to place the data in columns. For more
information about data groups, see Data Sorting and Grouping: General Information.

• Behavior > TabularReport: The True value means that the report is tabular.

• Behavior > TabularFreeze: The value of this property, a number of pixels or centimeters,
specifies the position of the red vertical line in the report layout. The line passes through all the
group headers, the group footers, and the detail sections of the tabular report. You should use the
topmost group section for the columns of the tabular report and place columns to the right of the
red line. A new column is created for each new group of the data of this group section.

• Layout > Width: The value of this property, a number of pixels or centimeters, specifies the width
of the report if it had only two columns—that is, the first column and the column that presents
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a series of columns. The difference between the values in Layout > Width and Behavior >
TabularFreeze specifies the width of the column in the series of columns.

Tabular Reports: To Create a Tabular Report

In the following activity, you will learn how to create a tabular report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager has requested a report that shows the quantity of inventory items ordered by
customers. You have looked through the reports in the Sales Orders workspace and suggested that
the manager use Sales Order Details by Customer (SO611000) report. The sales manager said that the
report should give salespeople the ability to compare the quantities of inventory items for different
customers—that is, to display the quantities of an inventory item for different customers in the same
row, with a separate row for each inventory item.

Process Overview

In the Report Designer, you will open the SO6110C1 report, which is a copy of the Sales Order Details 
by Customer (SO611000) report and modify the copy to make the report a tabular one. You will 
change grouping conditions for the data in the report, delete the groups and text boxes that you do 
not need from the report layout. (You will not make any modifications in the Schema Builder.)

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the SO6110C1.rpx file.

2. Open the uploaded file in the Report Designer.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=902a6862-8e9b-444c-8f48-c7c908574133
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=902a6862-8e9b-444c-8f48-c7c908574133
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3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type SO6110C1 as the report name, and click OK.

The report is saved on the server.

Step 1: Changing Grouping Conditions for the Report

Because the data in the report should display quantities of inventory items for different customers, you
need to group data in the report by inventory items and by customers. That is, you need to change
grouping conditions for the report.

To change grouping conditions for the report, do the following:

1. In the Report Designer, be sure the SO6110C1 report (which you have saved to the server) is
open.

2. In the top left corner of the Design pane of the Report Designer, click the  icon to select the
report, and in the Data > Groups property, click the  button.

3. In the Group Collection Editor window, which opens, in the Members pane, select group1.

4. In the group1 properties pane on the right of the Group Collection Editor, in the Behavior >
Grouping property, click the  button.

5. In the GroupExp Collection Editor, which opens, in the Members pane, select the second
PX.Reports.GroupExp member and click Remove to delete it. For this member, on the right
pane, the Misc > DataField property is set to BAccount.AcctName.

6. Click OK to close the GroupExp Collection Editor.

7. In the Group Collection Editor window, in the Members pane, select group2.

8. In the group2 properties pane on the right of the Group Collection Editor, in the Behavior >
Grouping property, click the  button.

9. In the GroupExp Collection Editor, which opens, on the right pane, for the Misc > DataField
property set the SOLine.InventoryID value.

10. Click OK to close the GroupExp Collection Editor.

11. Click OK to close the Group Collection Editor.

12. On the Report Designer window toolbar, click Save.

Step 2: Modifying the Report Layout

To modify the report layout, do the following:

1. In the Report Designer, be sure the SO6110C1 report (which you have saved to the server) is
open.

2. Delete all the elements from pageHeaderSection2, or delete this section.
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3. In groupHeaderSection1 (Header of group1), delete the text box with the
=[BAccount.AcctName] value and all the text boxes to the right of this text box.

4. Move the text box with the =[BAccount.AcctCD] value to the right.

5. From the Tools pane, drag TextBox element to groupHeaderSection1 (Header of group1), and
type Inventory Item for the Appearance > Value property of the added text box.

6. Select groupHeaderSection3 (Header of group1), and delete all the text boxes in the section.
You can also delete this section. To do this, in the context menu, click Delete.

7. In groupDetails, select the text box with the =[SOLine.InventoryID] value and copy and
paste it to groupHeaderSection2 (Header of group2), to the left, below the text box with the
Inventory Item value in groupHeaderSection1 (Header of group1).

8. In groupFooterSection2 (Foorter of group2), select the text box with the
=Sum(isnull([SOLine.OrderQty]*-[SOLine.InvtMult],0)) value and copy and paste it to
groupHeaderSection2 (Header of group2), below the text box with the =[BAccount.AcctCD]
value in groupHeaderSection1 (Header of group1).

9. Select groupHeaderSection2 (Header of group2) and for its Behavior > Visible set the True
value to make the content of the section visible.

10. In groupFooterSection1 (Footer of group1), on the left, add a text box with the Total: value.

11. In groupFooterSection2 (Foorter of group2), select the text box with the
=Sum(isnull([SOLine.OrderQty]*-[SOLine.InvtMult],0)) value and copy and paste it to
groupFooterSection1 (Footer of group1), right of the text box with the Total: value.

12. In groupFooterSection2 (Footer of group2), delete all the elements.

13. Delete all the text boxes from groupDetails.

14. Reduce the height of groupDetails, groupFooterSection2 (Footer of
group2)groupFooterSection3 (Footer of group2) as much as you can.

You can set the value of the Appearance > Height property of these sections to 0px. You can also
delete these sections because they do not contain any elements.

15. Optional: To improve the readability of the report, place four line elements in the following
positions:

• In groupHeaderSection1, below the text box with the Inventory Item value

• In groupHeaderSection1, below the text box with the =[BAccount.AcctCD] value

• In groupHeaderSection2, below the text box with the =[SOLine.InventoryID] value

• In groupHeaderSection2, below the text box with the =Sum(isnull([SOLine.OrderQty]*-
[SOLine.InvtMult],0)) value

16. On the Report Designer window toolbar, click Save.

You can view the report (see the Step 4: Viewing the Report) to make sure that you have
modified the report layout correctly. Viewing the report before you make it a tabular one will
ease troubleshooting.
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Step 3: Specifying the Properties of the Report and Its Elements

To specify the properties of the report and its elements, while you are still working with the
SO61100C1 report in the Report Designer, do the following:

1. In the top left corner of the Design pane of the Report Designer, click the  icon to select the
report, and in the Behavior > TabularReport property, select True to make the report a tabular
one.

2. In the Behavior > TabularFreeze property, type 150px.

The red vertical line is displayed in the report. To the right of the red line, the customers and the
quantity of ordered items will be displayed. Make sure that no element crosses the red line.

3. In the Layout > Width property, type 320px.

4. Optional: To make a uniform alignment of elements in the report, in groupHeaderSection2
(Header of group2), select the text box with the =Sum(isnull([SOLine.OrderQty]*-
[SOLine.InvtMult],0)) value and for its Appearance > Style > TextAlign property, select
NotSet. Repeat the same action for the text box with the same value in the groupHeaderSection1
(Footer of group1).

5. On the Report Designer window toolbar, click Save.

The report in design mode is shown in the following screenshot.
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Figure: The tabular report in design mode

Step 4: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Sales Order Details by Customer (SO6110C1) report form by
searching for its identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the Report Parameters tab, in the Start Date box, select 1/1/2020, and in the End Date
box, select today's date.

3. On the report form toolbar, click Run Report.

Make sure that the report displays data for all customers and that the data about the quantity of orders
for each customer is displayed in a separate column. (You can compare the list of customers in the

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401


| Lesson 8: Developing Tabular Reports | 102

SO6110C1 and SO611000 reports with the same name.) The resulting report is shown in the following
screenshot.

Figure: The Sales Order Details by Customer (SO6110C1) tabular report
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Lesson 9: Exporting Reports

Report Export: General Information

Acumatica ERP reports can be exported as XSL and PDF files. In the Acumatica Report Designer, you
can specify settings to export a report as an XSL file.

Learning Objectives

In this chapter, you will learn how to export report results by using the Report Designer.

Applicable Scenarios

You may need to learn about the exporting of report results in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to export reports from Acumatica ERP to send them by email or to use them for further
processing in Excel.

Export of Reports in Acumatica ERP

In Acumatica ERP, you can export any report, predefined or custom. The system has two options of
export, as an XSL file or as a PDF file.

To export a report in Acumatica ERP, you run the report, and on the report toolbar, you select one of
the following menu commands, based on the format you need:

• Export > Excel: If you plan to export a predefined or custom report as an XSL file, then in the
Report Designer, you can configure the report's settings in advance.

• Export > PDF: The system exports the report to a PDF file as is; you cannot configure any
settings of this report.

Excel Mode for Export

In the Report Designer, you manage the export settings of a report to XSL file by using the Layout >
Excel Mode property. By default, this property of any newly created report is set to Auto. With Auto,
some reports are exported readably. Other reports exported to an XLS file can have displaced cells with
data in the grid. These reports are difficult or even impossible to read. For these reports, before report
generation and export, you need to mark up cells and columns in the Report Designer. To do this, you
set the Layout > Excel Mode property to Manual and then specify the needed settings. To prepare a
report for export, you can perform the following actions (which are further described in the remaining
sections of this topic) in the Report Designer:

1. Display the Excel column grid.

2. Adjust or define the list of Excel columns.

3. Define the row and column position of all report elements.

4. Adjust the position of each element.

5. Specify additional settings for margins between sections and export status of elements.
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After you specify all necessary settings, you save the report. It can be run and exported to Excel.

Display of the Excel Column Grid

To display the Excel column grid, on the menu bar of the Report Designer, you click View > Excel
Grid > Show Columns. In this display, each element on the report layout is marked with two
numbers divided by a colon (see the following screenshot).

Figure: Display of the Excel column grid for the report

These numbers mean the following:

1. The first number is the row in Excel worksheet to which the element content will be exported. This
number is specified by the value of the Layout > Excel Cell > Row property.

2. The second number is the column to which the element content will be exported. This number is
specified by the value of the Layout > Excel Cell > Column property.

In each section, the numbering of rows starts from 1. You can change the numbers of rows and
columns to define the order of elements within each exported section. You cannot change the order
of the sections in the exported report, however. You can generate the list of columns automatically
according to the number and width of elements of any section. For this purpose, you can use the
section with the maximum number of elements. You right-click the header this section, and then select
Generate Excel Columns.

If you need to refresh the Excel column grid, on the menu bar, you can click View > Excel
Grid > Hide Columns, and then click View > Excel Grid > Show Columns.

Adjustment or Defining of the Excel Columns

To adjust the number, order, and width of columns to export to Excel, you select the report and, in the
Layout > Excel Columns property, you click the  button to open the Int32 Collection Editor (that is,
the Int32 Collection Editor dialog box), as shown in the following screenshot.
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Figure: Use of the Int32 Collection Editor to adjust the exported columns and their width

In the Members pane of the Int32 Collection Editor, the first number corresponds to the order of the
column in the Excel grid. 0 is the first column (A) of the Excel grid, 1 is the second (B), and so on. To
specify the width of each column, you click the column in the Members pane; then you specify the
Value property of the right pane of the Int32 Collection Editor. The column width corresponds to the
element width in pixels in an approximate 1:6 ratio. For example, the width of a column with a Value
of 10 is approximately equal to the width of a text box with a Size > Width of 60px.

Based on the settings in the screenshot above, the report will be exported to Excel with the following
settings:

• The report will have columns from A (which corresponds to 0) to L (which corresponds to 11).

• The A column will have a width of 10.

Row and Column Positions of Report Elements

To define the row and column position of all the report elements, on the Report Designer menu bar,
you click Edit > Adjust Excel Layout. The Report Designer automatically changes the row and
column position of all the report elements depending on how they fit the Excel columns.

This functionality exports the report as expected for simple report layouts but may cause unexpected
results for some complicated layouts. We recommend that you assign the row and column position for
report elements automatically. You can adjust the positions manually later, in Excel, if needed.
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Similarly, you can define the row and column position of the elements of any particular
section. You right-click the section header, and then select Adjust Excel Layout.

The Position of Each Element

In the Report Designer, you use the Layout > Excel Cell > Row and Layout > Excel Cell > Column
properties to adjust the position of each element in a report.

Additional Settings

In the Report Designer, you can specify the following additional settings for a report:

• Margins between sections: You specify this setting (in number of rows) in the Layout > Excel
Margin > Top and Layout > Excel Margin > Bottom properties.

• Export status of an element: If you don’t want to export a particular element of the report to Excel,
you select the element and, in the Layout > Excel Visible property, select False. By default, the
property is set to True.

The export of SubReport, Chart, Line, and ImageBox elements to Excel is not supported.
Also, if you want to export the contents of a Panel element to Excel, you should specify
the position—a row and a column—of each element inside the panel.

Report Export: To Export a Report as an XLS file

In the following activity, you will learn how to export a report to an XLS file.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager of your company has requested the Vendor Summary (AP655000) report in XLS format.
The sales manager plans to process the data further in Excel. You plan to use a copy of the report;
after checking its settings, you will run the report and export it.

Process Overview

In the Report Designer, you will open the AP6550C4 report, which is a copy of the Vendor Summary 
(AP655000) report. You will make sure that the report is simple and can be exported without 
additional settings being specified. Then in Acumatica ERP, you will run the report and export it as 
an XLS file.
System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
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2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C4.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C4 as the report name, and click OK.

The report is saved on the server.

Step 1: Checking the Export Setting

To check the report's export setting, do the following:

1. In the Report Designer, be sure the AP6550C4 report (which you have saved to the server) is
open.

2. In the top left corner of the Design pane of Report Designer, click the  icon to select the report,
and set the Layout > Excel Mode property to Auto.

Step 2: Exporting the Report as an XSL File

To export the report, do the following:

1. In Acumatica ERP, open the Vendor Summary (AP6550C4) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. On the report form toolbar, click Run Report.

The report is displayed.

3. On the report toolbar, click Export > Excel.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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The XSL file with the name consisting of the name of the report (Vendor Summary) and the
current date is uploaded to the default folder on your computer.

4. Open the XSL file and make sure that it looks the same as the original report in Acumatica ERP.

The following screenshot shows the result of the export in Excel. Make sure that the report in Excel
looks similar to the report in Acumatica ERP.

Figure: The exported Vendor Summary (AP6550C4) report opened in Excel
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Lesson 10: Localizing Reports

Report Localization: General Information

Acumatica ERP provides built-in localization functionality. In the Acumatica Report Designer, you can
localize any report, so that a user can run this report and view the result in the language they selected
when signing in to Acumatica ERP.

Learning Objectives

In this chapter, you will learn how to localize a report in the Report Designer.

Applicable Scenarios

You may want to learn about report localization in the following circumstances:

• You are responsible for the customization of Acumatica ERP in your company, including developing
and modifying reports to give users the information they need to do their jobs.

• You need to provide reports in different languages.

The Objects of Localization

To localize a report, you have to translate its source strings, which include form names, element labels,
parameters, predefined values of parameters, and constant strings of variables and formulas. On the
Translation Dictionaries (SM200540) form, you can collect, filter, and then translate any strings of the
Acumatica ERP forms, including reports, both predefined reports and those designed by using the
Report Designer.

The value of the Behavior > Localizable property, which can be specified in the Report Designer for
a report, determines the multiple language support of the report. You can specify this property for
the whole report, as well as for each element, such as a text box. The default value of this property is
True, indicating that multiple languages are supported for report elements.

Process of Report Localization

To localize a report into a language, you perform the following general steps on the Translation
Dictionaries (SM200540) form:

1. You collect the report strings to be translated.

2. You select the language or languages to which you want localize your report.

3. In the collection of strings, you find the strings related to the report and type your translation.

4. You save your translation.

You can also collect strings also on the Translation Sets (SM211500) form, as described in the next
section.

To localize any resources of Acumatica ERP, make sure that the languages to which
resources will be localized are selected on the System Locales (SM200550) form.

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=e00684d5-0b77-41f1-8a36-b4365d4a0d9f
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=6b40927b-3288-4ccd-bd7f-786fb246b9ac
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Collection of Strings for Translation

When you localize the system for the first time, or after you update or publish any report that you
want to be localized, you should collect the strings to be translated. In Acumatica ERP, all the strings
are considered as bound or unbound. Bound strings are strings associated with system resources
bound to forms, such as table names. Unbound strings are strings associated with unbound resources
—resources, such as prompts, that are not bound to forms. Any reports are also considered to be
unbound resources. You can collect particular unbound resources used in reports.

You can collect the report strings for translation in one of the following ways:

• On the Translation Dictionaries (SM200540) form. You click Collect Strings on the form toolbar to
collect all the strings used in the system, including the report strings. This operation can be time-
consuming.

• On the Translation Sets (SM211500) form. You create a new translation set with the following
options selected in the Unbound Resources To Collect box:

• Chart Name

• Constant in Formula

• Prompt

• Text Box Value

• Valid Value
You select these types of elements because reports include only elements of these types. Then
you save the translation set and click Collect on the form toolbar to collect all the strings of the
translation set.

This operation may also take a significant amount of time, but less time than the collection of
strings on the Translation Dictionaries form.

Report Localization: To Localize a Report

In the following activity, you will learn how to localize a report.

The following activity is based on the U100 dataset. If you are using another dataset, or if
any system settings have been changed in U100, these changes can affect the workflow of
the activity and the results of the processing. To avoid any issues, restore the U100 dataset
to its initial state.

Story

Suppose that you are a technical specialist in your company who is working on simple customizations.
A sales manager of your company has requested that you localize the predefined Vendor Summary
(AP655000) report to the Italian language. You will localize a copy of the predefined report, starting
with a test of the capability in which you localize the report header and table header.

Process Overview

In the Report Designer, you will open the AP6550C5 report, which is a copy of the Vendor Summary 
(AP655000) report, and make sure that it can be localized. On the System Locales (SM200550) form, 
you will add

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=e00684d5-0b77-41f1-8a36-b4365d4a0d9f
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=b61831e2-2f54-45d0-af17-b07fa1595890
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=6b40927b-3288-4ccd-bd7f-786fb246b9ac
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the Italian language. On the Translation Dictionaries (SM200540) form, you will collect strings, select the
language, and type a translation for the strings related to the needed report. To experiment with the
capability, as a translation, you will use the same string as the original ones with $$ as a prefix and
suffix. You will localize the report header and the table header in the report.

System Preparation

Before you perform the steps of this activity, make sure that the following tasks have been performed:

1. You have installed the Acumatica Report Designer, as described in Report Designer: To Install the
Acumatica Report Designer.

2. You have installed an Acumatica ERP instance with the U100 dataset, or a system administrator
has performed this task for you.

3. You have signed in to Acumatica ERP with the following credentials:

• Username: gibbs

• Password: 123

The gibbs user is assigned the Administrator role and the Report Designer role. Thus,
this user has sufficient access rights to manage system configuration and to preview,
save, and publish reports.

Also, to prepare to use the file intended for this activity, do the following:

1. Upload the AP6550C5.rpx file.

2. Open the uploaded file in the Report Designer.

3. In the Report Designer menu bar, select File > Save To Server, which opens the Save Report
on Server dialog box.

4. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, type AP6550C5 as the report name, and click OK.

The report is saved on the server.

Step 1: Localizing the Report

To localize the report, do the following:

1. In the Report Designer, open the  report.

2. On the Report Designer menu bar, click File > Save To Server, which opens the Save Report on
Server dialog box.

3. In the dialog box, specify the connection string and sign-in credentials of your Acumatica ERP
instance, enter AP6550C5 as the report name, and click OK.

The report is saved on the server.

4. In the top left corner of the Design pane, click the  icon to select the report, and make sure that
the Behavior > Localizable property of the Properties tab is set to True (which is the default
value).

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
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5. In Acumatica ERP, open the System Locales (SM200550) form, add a new row, and specify the
following settings in the added row:

a. Locale Name: it-IT

b. Locale Name in Locale Language: Italiano

c. Description: Italian

d. Sequence: 2

e. Active: Selected

6. In Acumatica ERP, open the Translation Dictionaries (SM200540) form, and on the form toolbar, click
Collect Strings.

The process can be time-consuming.

7. In the Language box, select Italiano.

You can select two or more languages if you want to translate the report into multiple
languages simultaneously.

8. Select the Show Only Unbound check box.

Based on this selection, all unbound strings, including report strings, will be shown on the
Collected tab of the form.

Because you decided to translate only the report heading and table headings that are
TextBox elements, in the Unbound Resources To Display box, you can select Text
Box Value.

9. On the Collected tab, in the lookup box below Default Values, type the string you are looking for
to find the particular string of your report, such as Vendor Summary.

10. In the Source Value column of the Default Values table, click the string that exactly matches
the string in the AP6550C5 report. To look for a string in a long list, use the arrow buttons below
Default Values.

In the Key column of the Key-Specific Values table, all elements that use the string are listed.

When you look for the string in the Default Values table, make sure that in the Key-
Specific Values table, the Key value is AP6550C5.rpx textBox11.Value. You need to
look for this value because in the Report Designer, the Vendor Summary string is the
value of the Appearance > Value property of the text box element with the textBox11
value of the Design > (Name) property.

11. In the Italiano column of the Default Values table, type your translation—that is, $$Vendor
Summary$$.

12. On the form toolbar, click Save.

13. Repeat the four previous instructions to find and translate the following strings of the report:

• Vendor

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=6b40927b-3288-4ccd-bd7f-786fb246b9ac
https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=74cad436-94ee-4598-b1ff-a886d54088b4
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• Vendor Name

• Status

• Class

• Terms

• Vendor Currency

• Tax Zone

• Phone

• FAX

• Current Balance

• Balance Currency

Step 2: Viewing the Report

To view the report, do the following:

1. In Acumatica ERP, open the Vendor Summary (AP6550C5) report form by searching for its
identifier.

This report, which you have modified in this activity, has been published in the U100
dataset. That is, it has been added to the Site Map (SM200520) form, and you can
access it in Acumatica ERP.

2. In the Locale box of the Report Parameters tab, select Italian.

3. On the report form toolbar, click Run Report.

The following screenshot displays the localized report. Make sure that the report heading and the
strings in the table heading have $$ as a prefix and suffix.

Figure: The localized AP6550C5 report

https://help-2021r1.acumatica.com/Help?ScreenId=ShowWiki&pageid=44b364ef-7810-400b-b1c6-8f471c249401
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